Replaced old spa air blower and still not working right

BurninMoney

Active member
Jul 5, 2017
25
Fort Worth, TX
Spa air blower stopped working. Assumed old one dead and it gave me reason to replace it anyway. Purchased and DIY installed. Old: Model 1-516-03 1.5 HP 240v 4a 60hz. New: Silencer 1.5 HP 240v 3.8a. Installed a 240v toggle switch on blower. Blower Connected to a Lens Gordon 240v relay that’s connected to a Lens Gordon air switch.

new blower works for 3-5 minutes and stops. I turn it off at blower switch. Come back after a few hours and turn back on and it works for another 3-5 minutes and stops. rinse and repeat. Notice also the water back flow preventer is bobbing up and down and making noise. Old one didn’t have that so I don’t know if that’s normal.

Other symptoms - I’ve had issues with the air switch not working right. I’ve plugged directly to it and bypassed the line to the spa. It switches once but subsequent pushes of the button won’t work.

Questions:
- Is it possible my relay is going bad?
- Is it possible that even if I used the same specs on the blower, that it’s too powerful?
- is the noise from the back flow preventer normal?
 

rcerf

Gold Supporter
Aug 22, 2019
62
Bastrop , Tx
Pool Size
5300
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-9)
Had the same problem with our blower when the spa was built. It would stay on for a few minutes then shut off. Let it cool down and it would come back on briefly. Found out it was creating to much back pressure and overheating , causing the thermal switch to shut it down. The fix was to drill a couple of quarter inch holes in the pvc pipe right below the blower to relieve some of the back pressure. Problem solved.
 

BurninMoney

Active member
Jul 5, 2017
25
Fort Worth, TX
Update for anyone that searches for this — fixed! Turns out, when I put the top of the blower on, the foam was not setting correctly and covered the hole that sucks in air to the motor. It’s been fixed for two months now running strong and regularly! Check your foam if you have this issue!
 
  • Like
Reactions: mknauss
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.