Dolphin Nautilus CC Plus

morzh

Well-known member
Jul 3, 2015
253
Jackson, NJ
This is my review I wrote for Amazon with some additions. I bought this cleaner in June 2020.

It started very well. Compared to my untimely deceased Diamond this one cleaned my pool the very first time I put it in to a sparkling shine.

Yes, before putting it in the water, I checked the collection bags (they have Spring Clean ones installed) and found a metal rod inside one of them. Good thing Ii checked (they say you could put it right in) as it could possibly puncture the bag's screen, get near impeller and break it.
When I called the company, they failed to indentify the rod and said it is something that did not belog in it. Not a spare part either.

It had been just under 3 weeks when in the morning I went to the pool to sweep some dirt that fell after the rain and then I noticed that the Dolphin stood still in one place blowing the jet out of the exhaust. I waited 2 minutes, it kept doing it. So, methought, OK, glitch in the software, reset, and I cycled the power.
Same result. OK, me thought, maybe it got to some awkward place and needs to be moved. So I did move it. Same thing.
Took it out, found out one of the covers was slightly open, took out the filters, cleaned them, closed the covers, put the Dolphin in, same thing.
Then I took it out again, and upon laying it on a side, I noticed one track was off the rollers. It was not easily noticeable as the color of the track is close to that of the roller.
I put it back and then the Dolphin started moving.
There was no reason for it: no large debris was in the pool that could've displace the track, else (the pool was clean) it would end inside the filter and I would see it upon cleaning.

That was a bit alarming. What if I were to go away for a few days and left the Dolphin in? It would then do nothing sitting there waiting for me to rescue it


Over the course of the summer this happened several times, and I had to realign the track. Then for a month there was nothing.
Last Saturday something happened that was worse.
The track came off (I notice this when my pool looked unkempt and the robot sat there in one place running the impeller and not moving) but when I realigned it, it refused to move. I took it out again and I heard crackling sound. I looked inside where the track goes and saw it having come off the internal part (whether it is a curved track path or an idler - I do not know). And the track is rigid enough for me to not be able to do it from the outside with little effort, like before.
I was able to fix it, but this done in cool weather with the rain starting......I had to open the hatches, unscrew the screws and take the top off. Then pushed the track under, then replaced the cover (took me 5 minutes to make it snap in place) and tightened the screws. Then it worked.

Again. It is an excellent pool cleaner. When it works. Unfortunately, it is highly unreliable. The workmanship is just not there. Possibly molded parts with poor tolerances. Also, I am not sure it is an assembly defect.
Somehow I think it also might be a universal defect due to the way it brakes one track in order to turn. Cannot be sure.
Would be interested to hear from other owners.

Disappointed. I gave it 2 stars on Amazon.

PS. The company offered to send it back in (warranty plus the shipping is on them), which I probably will hold then to, but sending it in right now means I am left without the pool cleaner now when the leaves are just starting to fall.
 
Last edited:

Bperry

Gold Supporter
Aug 20, 2020
99
Knoxville, TN
This is my review I wrote for Amazon with some additions. I bought this cleaner in June 2020.

It started very well. Compared to my untimely deceased Diamond this one cleaned my pool the very first time I put it in to a sparkling shine. It had been just under 3 weeks when in the morning I went to the pool to sweep some dirt that fell after the rain and then I noticed that the Dolphin stood still in one place blowing the jet out of the exhaust. I waited 2 minutes, it kept doing it. So, methought, OK, glitch in the software, reset, and I cycled the power.
Same result. OK, me thought, maybe it got to some awkward place and needs to be moved. So I did move it. Same thing.
Took it out, found out one of the covers was slightly open, took out the filters, cleaned them, closed the covers, put the Dolphin in, same thing.
Then I took it out again, and upon laying it on a side, I noticed one track was off the rollers. It was not easily noticeable as the color of the track is close to that of the roller.
I put it back and then the Dolphin started moving.
There was no reason for it: no large debris was in the pool that could've displace the track, else (the pool was clean) it would end inside the filter and I would see it upon cleaning.

That was a bit alarming. What if I were to go away for a few days and left the Dolphin in? It would then do nothing sitting there waiting for me to rescue it


Over the course of the summer this happened several times, and I had to realign the track. Then for a month there was nothing.
Last Saturday something happened that was worse.
The track came off (I notice this when my pool looked unkempt and the robot sat there in one place running the impeller and not moving) but when I realigned it, it refused to move. I took it out again and I heard crackling sound. I looked inside where the track goes and saw it having come off the internal part (whether it is a curved track path or an idler - I do not know). And the track is rigid enough for me to not be able to do it from the outside with little effort, like before.
I was able to fix it, but this done in cool weather with the rain starting......I had to open the hatches, unscrew the screws and take the top off. Then pushed the track under, then replaced the cover (took me 5 minutes to make it snap in place) and tightened the screws. Then it worked.

Again. It is an excellent pool cleaner. When it works. Unfortunately, it is highly unreliable. The workmanship is just not there. Possibly molded parts with poor tolerances. Also, I am not sure it is an assembly defect.
Somehow I think it also might be a universal defect due to the way it brakes one track in order to turn. Cannot be sure.
Would be interested to hear from other owners.

Disappointed. I gave it 2 stars on Amazon.

PS. The company offered to send it back in (warranty plus the shipping is on them), which I probably will hold then to, but sending it in right now means I am left without the pool cleaner now when the leaves are just starting to fall.
Mines been going strong for several months. I take it out of the pool during the summer but since the leaves started to fall it’s been in there running every day.
 

DanF

Silver Supporter
Mar 17, 2019
307
Chandler, AZ
I understand your not wanting to send it in right now due to the leaves, but make sure your warranty is still good when you are ready to return it.