Aqua Rite suddenly not working

deisher

New member
Aug 14, 2010
3
Have a aqua rite generator 3 yrs old. Suddenly not working. Have replaced the fuse, the tcell-15 When i turn back on it blinks no flow rapidly for 30 + seconds then goes blank. I checked the flow switch and it looks ok not obstructed. Last salt level sev wks ago was 3300. Live in midwest where it is very warm right now with pool temp 94! no cover on PH ok. Any ideas what to check next. I wonder if I need a new circuit/control board but not sure where to find one. The local pool dealers did not install this SWG and have no experience with aquarite but would be happy to install a intellchloinator for $2000+ Any suggestions would be appreciated.
 

flintstone

LifeTime Supporter
Jul 17, 2007
99
Rockville, CA
You need to be certain there are no small nicks in the wire leading from the box to the sensor. It may be best to remove it so you can examine it very closely. After three years the wire gets pretty fried and can become damaged simply by moving it. There are ways to diagnose a sensor problem that may be found on this site. I am sorry I can't help you more than suggesting a fix to the same problem I had, but I don't know the difference between a volt and an ohm.
 

El

New member
Aug 15, 2010
1
I have encountered this same issue with Aqua Rite units.
Check the upper right corner of the main PCB for a large black capacitor-like component. Look closely for any cracking or scorching on or around this component. If you discover any of the afore mentioned, get out your soldering iron. This component is an In-rush Current Limiter part #SL32 2R025 which acts as a combination varistor and fuse to protect the rest of the board from current spikes. Replacement cost is around $2.50 at Digikey.com versus $350 or so for a new PCB.
http://parts.digikey.com/1/parts/705753 ... 2r025.html
The PCB is easily removed from the box and the wiring post connections are color coded for a no-brainer reinstall. The whole process generally takes about 30-40 minutes from start to finish.
:cheers:
 

deisher

New member
Aug 14, 2010
3
Replaced the black disk and everything is working well. Thanks for the advice Ordered a backup at same time in case the weather damages it again in a few years.