Anyone in the Northeast open yet?

rmclain73

Silver Supporter
May 18, 2013
151
Needham, MA
#1
My pool is scheduled to open on 4/20. However, with temps in the mid 60s today, and in the 70s and 80s over the next few days, I am thinking of pushing ahead my opening to this week. As of today my water is crystal clear when I peek through the mesh cover. I would like to open to that. Not sure what the temp though.
 

brtims

Bronze Supporter
Jul 25, 2016
16
Nazareth PA
#2
Yes. I am in Northeast PA and pool was opened by me this weekend. Let the solar cover do its magic for the next month :). The water is freeeeezing :)
Opened crystal clear as well so I wanted to keep it that way.
 

pooldv

Mod Squad
TFP Expert
Platinum Supporter
LifeTime Supporter
Aug 10, 2012
24,993
DFW, TX
#3
Open your pools before the water gets to 60. Or pour in some bleach and mix it around to maintain FC level.
 

Veccster

Bronze Supporter
Aug 30, 2016
353
Pittsburgh PA
#4
We are still in the build process but had water put in last fall and a cover put on. The cover comes off today, concrete decking poured tomorrow and equipment will be wired up by Friday. If the weather looks decent in the next week or so, I'll fire up the heater so the kids can get their first swims in.
 

johncunningham

Bronze Supporter
Aug 18, 2015
10
boston
#7
Metro west Boston. Cover came off today. Water is 48F. Kids are excited. Before our mesh cover came off, you could see the screw heads on our main drain cover. Now, after brushing and running the Polaris it's pretty hazy. Hopefully it will clear in a day or so of running the filter, Polaris, and brushing. I'm surprised at how high my pH was. Off the scale. Acid demand didn't seem to make a change after 20 drops. I just added a gallon of muriatic acid and will check tomorrow. It's our first time opening, so I don't really know what to expect. Hoping to use the spa in the next few days.
 

kcindc

Gold Supporter
LifeTime Supporter
TFP Guide
Sep 2, 2011
1,282
Fairfax, VA
#9
Washington DC metro, opened last Friday with a some algae. Luckily, it wasn't too bad and I'm almost finished with my SLAM despite a leak in my DE filter. I would open ASAP!
 

CJadamec

TFP Expert
Apr 29, 2016
2,194
Quaker Hill, CT
#11
Thought I had more time till the water got warm but the temp probe I stuck in the pool yesterday says 56. The winter cover seems to make for a very effective solar cover. Water is still crystal clear I'd like to keep it that way.
 

richierich

Bronze Supporter
Jul 12, 2013
579
Long Island, NY
#13
Is it ok to 'open' your pool but still have the winter cover on until all the pollen is gone? I added my stabilizer and my bleach but put the winter cover on. I'm trying to avoid the pollen that my neighbors tree goes into my pool. I am running the pump a few hours a day. I plan on taking the cover off in May
 

CJadamec

TFP Expert
Apr 29, 2016
2,194
Quaker Hill, CT
#14
By "open" most people are talking about bring the water level back to normal and getting all the circulation equipment going so they can maintain water chemistry. For some that just means opening valves and turning on the pump. For others it mean bringing pumps and plumbing out of the basement or garage and hooking them up again. If you are circulating water and maintaining the chemistry you have "opened" your pool. Keeping the cover on to keep the pollen out won't hurt anything.
 

rmclain73

Silver Supporter
May 18, 2013
151
Needham, MA
#15
Well I did my opening today. Closed following TFP guidelines, and I opened to crystal clear water. Here were my numbers after two hours of running my pump prior to adding anything.

FC: 2.0
CC: 0.0
PH: 7.2
TA: 70
CH: 190
CYA: 60
Temp: 47 degrees

I had very little leaves in the pool. The polaris had it looking like it does on any given day in the summer in a couple of short hours. I gave the floor and walls a good brushing. Brought the level up to slam. Once the water warms up more I will switch on the the SWG. I am sure I will need to add some salt prior. I will test for that closer to that time. I'll check in a few hours to make sure my FC is holding. Once the level drifts down I will do a OCLT.

Here is a pic just 3 hours after open.

 

Ajayabb

Active member
May 11, 2013
26
South Jersey
#16
Well I did my opening today. Closed following TFP guidelines, and I opened to crystal clear water. Here were my numbers after two hours of running my pump prior to adding anything.

FC: 2.0
CC: 0.0
PH: 7.2
TA: 70
CH: 190
CYA: 60
Temp: 47 degrees

I had very little leaves in the pool. The polaris had it looking like it does on any given day in the summer in a couple of short hours. I gave the floor and walls a good brushing. Brought the level up to slam. Once the water warms up more I will switch on the the SWG. I am sure I will need to add some salt prior. I will test for that closer to that time. I'll check in a few hours to make sure my FC is holding. Once the level drifts down I will do a OCLT.

Here is a pic just 3 hours after open.

Looks great
I'm thinking about opening this weekend here in South Jersey
 

run53

LifeTime Supporter
May 4, 2010
347
#17
I'm in Massachusetts near the NH border. Stuck a thermometer down about 3 feet and it's reading mid 40's so I will wait till it hits 55 or so. Usually early May that happens for me.
 

ntobik

Well-known member
Jul 31, 2015
98
Pittsburgh, PA
#20
I need to open soon. Water about 6" down is high 50s, surface 65. I cracked my multiport and need to re-plumb my entire pad. I'm considering pulling the cover off, dumping in some chlorine and circulating with a small sump pump.

Hoping to have things open and running in a week. In Pittsburgh, PA.