3 cups of DE to sand filter and almost no pressure rise

SyncLock

New member
Aug 30, 2019
2
Gulf Coast, AL
Same story as another old thread:
Adding DE to Sand Filter - 3 cups and no pressure rise?

I've got a 26" sand filter (Pentair 145333 SD-80) and a 1hp single speed pump.

Started at 14.5 psi after a backwash. Added a 1/4 cup of DE, another 1/4, then 1/2 cups until I got to 3 cups. Pressure only went up .5 to 15 psi and then didn't increase anymore for over 24 hours. My water was already clear so I wasn't expecting a big jump, just concerned I couldn't get a full 1 psi gain after 3 cups of DE.

Do I keep adding DE until I hit 1 psi or is something wrong? If not, does that mean I can't use DE in my sand filter and get any benefit?
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Welcome to TFP! :wave: Kind of odd you're not seeing ANY changes really to speak of. Any chance your gauge is defective? Also, when was the last time you did a deep clean of the sand? I only ask because I wonder if the sand is compacted or channeled thereby effecting the DE process.
 

Chrissykr

Well-known member
Jun 8, 2014
488
Rogers, AR
I no longer use DE, I switched to Fiber Clear a couple of years ago, I never see a rise immediately. If your filter is anything like mine, it will sit there for a couple of days then all of a sudden it starts to build. Once my filter starts to rise it takes several hours and rises pretty steadily. I usually go about Three and a half days of running my pump for 11 hours a day on a backwash. When not using and DE/Fiber Clear I can go eight or nine days. I do live in a windy climate with lots of construction and tons of road construction so I get a lot of stuff in my pool.
 

SyncLock

New member
Aug 30, 2019
2
Gulf Coast, AL
Welcome to TFP! :wave: Kind of odd you're not seeing ANY changes really to speak of. Any chance your gauge is defective? Also, when was the last time you did a deep clean of the sand? I only ask because I wonder if the sand is compacted or channeled thereby effecting the DE process.
It's a new pool, pump, sand, etc. I believe the gauge is good, it certainly fluctuates when water features are turned on or off. Also I've previously seen it rise a few psi and drop again after backwashing.