Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Some water going to backwash while push pull valve should be closed

  1. Back To Top    #1

    Join Date
    Aug 2012
    Location
    Gilbert, AZ
    Posts
    130

    Some water going to backwash while push pull valve should be closed

    Hi everyone, just realized that my sand filter seems to be leaking into the backwash while it's filtering. I have a push pull valve, and found a few videos on youtube suggesting the o-rings might need to be replaced.

    Is this probably the issue, from those with experience? I don't know the brand filter (inherited when we got the house), but if I get the new 2 o-rings and some lubricant I should be able to just pop new ones on and it'll fix the issue? Doesn't seem like the valves are that much more complicated, and I'd rather not call a pool guy unless it's something serious. If I can fix it for 20 bucks vs. 100 or whatever most pool guys charge at a minimum I'd be happy.

    Thanks!
    12000-ish In Ground, plaster, sand filter. New variable speed pump (Hayward I believe)

  2. Back To Top    #2

    Join Date
    Aug 2012
    Location
    Gilbert, AZ
    Posts
    130

    Re: Some water going to backwash while push pull valve should be closed

    Quote Originally Posted by mgoblue View Post
    Hi everyone, just realized that my sand filter seems to be leaking into the backwash while it's filtering. I have a push pull valve, and found a few videos on youtube suggesting the o-rings might need to be replaced.

    Is this probably the issue, from those with experience? I don't know the brand filter (inherited when we got the house), but if I get the new 2 o-rings and some lubricant I should be able to just pop new ones on and it'll fix the issue? Doesn't seem like the valves are that much more complicated, and I'd rather not call a pool guy unless it's something serious. If I can fix it for 20 bucks vs. 100 or whatever most pool guys charge at a minimum I'd be happy.

    Thanks!
    I found this on Amazon, seems to be what I'd want:

    https://www.amazon.com/Hayward-Filte...CKRX4DVANQJBFV


    Not thinking I'd need to replace the actual valve assembly, right? It does appear to be Hayward as well though, these pics seem to be like what I have.
    12000-ish In Ground, plaster, sand filter. New variable speed pump (Hayward I believe)

  3. Back To Top    #3

    TFP Guide

    In the Industry

    Join Date
    Apr 2015
    Location
    tucson, arizona
    Posts
    1,314

    Re: Some water going to backwash while push pull valve should be closed

    SPX0410BA - Hayward - HANDLE AND PISTON ASSEMBLY is this your piston assembly? There are two piston O rings one larger than the other so you should easily see where they go

  4. Back To Top    #4

    Join Date
    Aug 2012
    Location
    Gilbert, AZ
    Posts
    130

    Re: Some water going to backwash while push pull valve should be closed

    Quote Originally Posted by kadavis View Post
    SPX0410BA - Hayward - HANDLE AND PISTON ASSEMBLY is this your piston assembly? There are two piston O rings one larger than the other so you should easily see where they go
    I really think so, it looks exactly like that and I can't imagine there are a lot of different models. My filter and everything has no labels on it (the paper label has long since faded) and I inherited this pool when we bought the house. I'll take another look at the rings when it's not dark out and i can fully remove the assembly. I was thinking of seeing if the pool places nearby have them, or just order on amazon, not sure.
    12000-ish In Ground, plaster, sand filter. New variable speed pump (Hayward I believe)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •