Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Pentair Challenger does not hold prime

  1. Back To Top    #1

    Pentair Challenger does not hold prime

    Hello,

    I am new to this forum, so if my question has been answered elsewhere, please let me know.
    This year, my Pentair Challenger starts give me problem: it requires me to prime everytime I start the pump. I had to open the strainer, fill the pot with water, close the lid and then the pump will prime almost immediately. If I turn it off, there are lot of air bubbles come up and then the water level goes down in the strainer below the suction line. If I dont manually prime, it will not work, even at one time I intended to let it run dry for 10 mins.
    I did basic trouble shootings:
    1- water level is above the skimmer
    2- Strainer lid and O-ring are good
    I am pretty sure the system worked fine last year, I only had to prime once when I opened the pool.

    Thanks for you help,

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    9,908

    Re: Pentair Challenger does not hold prime

    Sounds like you have a suction side leak somewhere. Air should not enter the plumbing when the pump is turned off.

    You said you checked the pump lid which is one source but it could also be any valve or even the pipe between the pool and pad. Until you find the leak, the problem will persist.
    Mark
    Hydraulics 101; Pump Ed 101; Pump and Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, 1/2 HP 2sp pump, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater, ThePoolCleaner

  3. Back To Top    #3

    Re: Pentair Challenger does not hold prime

    Thanks for the reply Mark,
    That is my guess, any idea how to detect such leaks on the suction side? If there is a leak on the valve, should the leaks have water comes out visibly?

  4. Back To Top    #4
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    Location
    SW Indiana
    Posts
    8,617

    Re: Pentair Challenger does not hold prime

    Have you tried lubing the strainer lid O-ring? When dry, the O-ring can be deformed by the twisting of the lid and allow air in. Have you checked the drain plugs on the pump? Any water drips as the pump shuts off?
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

  5. Back To Top    #5
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    9,908

    Re: Pentair Challenger does not hold prime

    First, I should of welcomed you to the forum in my last post but missed that you were new.

    Suction side leaks are a bit harder to find since they leak air into the plumbing system instead of water out of the plumbing system like a return side leak would cause.

    With a suction side leak, you should be seeing air in the pump basket even when the pump is running. Also, the filter should have a lot of air in it and some may make its way out the returns. Just to make sure of the problem, are you seeing any of these things?

    In addtion to what John suggested, use a hose to drench any valve that is on the suction side of the pump as well as the pump lid while the pump is running. If there is an air leak, then water should be drawn instead of air and the bubbles in the pump basket should disappear.

    Another option is to pressure test the plumbing system. This is a bit more involved since it requires capping off all returns and suction ports but if you live in an area where you winterize the pool, you may already have much of the equipment to do this. Pressure testing with water will allow you to see the water coming out of the suction side plumbing unless it is underground. That may require a bit more time before you see water pooling in the ground.
    Mark
    Hydraulics 101; Pump Ed 101; Pump and Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, 1/2 HP 2sp pump, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater, ThePoolCleaner

  6. Back To Top    #6

    Re: Pentair Challenger does not hold prime

    Thank you all,
    I'll try to find the leaks and let you all know.

  7. Back To Top    #7

    Re: Pentair Challenger does not hold prime

    Mark et al,

    Using a water hose and pour water on all joins of the suction line, I could not find any air leaks. then I bought a new O-ring online and replaced the old one although the old looks fine. It did help to seal the air inside the strainer. Water still came down at the level of the pump intake, but the now the pump can prime every time. So I guess the problem is solved for now. Thank you all for you help.

    Dinh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •