Recent content by SteverinoSD

  1. S

    Need Help Restoring Power After SAM Light Flooded

    Those are some great options... thanks for those insights Greg and Allen. I’ll look into the various replacement options, but I kinda think that the SAM light is muerto...
  2. S

    Need Help Restoring Power After SAM Light Flooded

    I activated the color wheel on the SAm lights by cycling the power at the Intellitouch controller. It would cycle slow or fast and you could also freeze it on a color that you preferred. I think we enjoy the colored lights, but rarely, if ever, use it in color-changing mode. We pretty much just...
  3. S

    Need Help Restoring Power After SAM Light Flooded

    Progress made... I removed the Intellitouch Panel and; Low and Behold! Look what I found! :p That sucker was hidden on the side of the panel obscured by a fence and a shrubbery! I reset the GFCI and powered on the recently-flooded SAm light and the circuit tripped immediately. I removed...
  4. S

    Need Help Restoring Power After SAM Light Flooded

    Another thought that I just had; Since there are 2 switches (pool lights & spa light), wouldn't there be two light relays in the Intellitouch panel? And, since turning both switches 'On' at the controller fail to illuminate either of the lights (spa light doesn't work, either), wouldn't the...
  5. S

    Need Help Restoring Power After SAM Light Flooded

    Thank you, Allen, for that great direction! I believe I understand what you're telling me. I'll open the panel tomorrow and check it out. However, in the mean time, looking at these two other photos of the junction box, I'm guessing that the blue wire might be the power lead from the panel for...
  6. S

    Need Help Restoring Power After SAM Light Flooded

    I realize that this is a recurring story, but I haven't been able to resolve the issue. One of my SAm lights flooded in my pool (2 in pool, 1 in spa) causing all 3 lights to stop working. A typical problem for a 15 year old pool, according to other accounts on this forum. After letting the light...
  7. S

    Help! Repaired Aquarite SWG went up in Flames... LITERALLY!

    Success! I attempted to measure the transformer and rectifier(s) voltage with the new board before plugging in the SC., but, I’m not real good with the multimeter, especially with live voltage. The meter only gave me .02 volts DC on the yellow wires out of the transformer when I powered it up...
  8. S

    Help! Repaired Aquarite SWG went up in Flames... LITERALLY!

    I just spoke with tech support for my Optima Simple Cell salt cell (Optima Pool Technologies in Corona, CA). The tech assured me that their salt cell would not be the culprit of my melt-down. He said that, even if cross-wired or not plugged in correctly, it would not have caused a shorting or...
  9. S

    Help! Repaired Aquarite SWG went up in Flames... LITERALLY!

    That’s great advice. I’ll take the SC to the pool store for testing. Here’s some from me: Only bet as much as your willing to lose! �� (BTW: you probably drove right past my house on your way to VVC if you took Old Castle Rd)
  10. S

    Help! Repaired Aquarite SWG went up in Flames... LITERALLY!

    Once again, your expert advice is greatly appreciated, Meadow! I will test the transformer before firing up the new board and I'll try to check the other components on the old board, as well. You don't think there's any chance of the salt cell being the culprit of the meltdown, do you? I...
  11. S

    Help! Repaired Aquarite SWG went up in Flames... LITERALLY!

    Thanks for the reply, Meadow. I don’t think I would feel comfortable putting that board back in, even if it were able to be repaired! I was about to order the new board, but hesitated because I wasn’t 100% sure that the GLX-PCB-RITE was the correct replacement. I, also, don’t want to spend a...
  12. S

    Help! Repaired Aquarite SWG went up in Flames... LITERALLY!

    Hello, I’m new to the forum. I am, also, a relatively new pool owner. It came with the home I bought about 1 1/2 years ago. The pool/equipment is ~14 years old (except for the Intelliflow VS pump I had installed about a year ago). The previous owner of the home did not replace his salt cell...