Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Taylor Speedstir DOA?

  1. Back To Top    #1

    Join Date
    May 2015
    Location
    Fullerton, CA
    Posts
    622

    Taylor Speedstir DOA?

    Just got my kit, and SS, put batteries in, light comes on but nothing happens with the power button??
    33x19, 3'4"-5'6", 7ft spa, baja reef, 14'x9', 18" deep, 10,668 Gal. Quartzite coping, Stonescape Tropics Blue mini-pebble, abalone & glass beads. Jandy Equip.(JXi heater, 2.7HPVS pump, PLC1400 SWG, CV580 filter, Aqualink, LEDs)
    TF-100, Doheny Discovery robot.

  2. Back To Top    #2

    Join Date
    Aug 2014
    Location
    Houston tx
    Posts
    2,494

    Re: Taylor Speedstir DOA?

    Is the little magnet thingy (I don't know what it's called!) in the tube? It won't work with out it. Ask me how I know....
    Marla
    No longer living vicariously through other people's pool builds. Pool build is complete on my IG SWCG pool, approx 10,000 gallons. All Jandy equipment - VS 1.5 hp pump, 580 cartridge filter, AquaPure 1400 salt cell, AquaLink PDA system. Dolphin m500. PebbleSheen Blue Surf with shells and beads added. TF-100 w/ SpeedStir. A Houston Pool Build Inside the Loop

  3. Back To Top    #3

    Re: Taylor Speedstir DOA?

    add the agitator "white pill looking thing" to the tube AFTER you have the water to the correct level.
    24' x 52" VINYL AG 15,200 GAL.
    HAYWARD POWER FLOW LX 1.5 HP
    HAYWARD SAND FILTER
    Taylor K-2006

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •