Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: pentair easy touch not " NO COMM "

  1. Back To Top    #1

    Join Date
    Dec 2015
    Location
    Arcadia
    Posts
    1

    Question pentair easy touch not " NO COMM "

    My remote is not communicating with system. My batteries are good where do I start?

  2. Back To Top    #2
    JoyfulNoise's Avatar
    Join Date
    May 2015
    Location
    Tucson, AZ
    Posts
    11,592

    Re: pentair easy touch not " NO COMM "

    Reset the EasyTouch panel. See if that corrects the problem.

    You should also check the antenna wiring (you have to remove the front of the panel to exposed the circuit board) and check that no wires are loose.


    Matt
    16k IG PebbleTec pool, 650gal spa, spillway and waterfall, 3HP IntelliFlo VS / 1.5HP WhisperFlo, Pentair QuadDE-100 filter, IC40 SWCG, MasterTemp 400k BTU/hr NG heater, KreepyKrauly suction-side cleaner Dolphin S300i robot, EasyTouch controls, city water, K-1001, K-2006 and K-1766 test kits, Mannitol test for borates

  3. Back To Top    #3

    Join Date
    Dec 2014
    Location
    Riverside California
    Posts
    473

    Re: pentair easy touch not " NO COMM "

    Welcome to the TFP forum. You can find the answer to most any question here provided by the many knowledgeable members. If it turns out that your remote is bad, consider replacing it with a Pentair Screen Logic interface. The Screen Logic makes the remotes obsolete. You can then control your Easy Touch with your PC and Apple / Android phones and tablets.
    38000 Gal, IG, Plaster, 20' x 40' x 10', Attached Raised Spa, Intelliflo VS 3 HP (011018), Pentair Quad DE 60 Filter, Raypak (Rheem) 400,000 BTU (407a low Nox), Easy Touch 8 upgrade, Screenlogic 2 with wireless, IS-4 Spa Side Remote, Stenner 45MPHP10 w/15 gal tank, Intellibrite 5g (3), Dolphin Triton Plus robot with PRO remote, Water Tech Catfish handheld vacuum for spa, TF100 with SpeedStir.

  4. Back To Top    #4

    In the Industry
    Pool Clown's Avatar
    Join Date
    Sep 2008
    Location
    Silicon Valley, CA
    Posts
    1,637

    Re: pentair easy touch not " NO COMM "

    I know this post is kind of dated but,

    Try resetting the address.

    From the load center at the equipment:

    press menu.
    press up arrow (scroll) to settings, press select (right arrow)
    scroll to address and press the right arrow button.
    wait till display says "sending address".

    From the hand held unit:

    Do the same:
    press menu.
    press up arrow(scroll) to settings, press select (right arrow)
    scroll to address and press the right arrow button to lock on to the unique address that is being sent from the outdoor panel.
    wait until display says "found addressed".
    press the menu button to save and exit this mode.

    Now return to the outdoor panel:
    press the menu button 3 times to exit the "sending address" mode.
    Factory Warranty Station for:
    Jandy/Zodiac, Pentair, Sta-Rite, Raypak, Polaris,
    and Paramount pool cleaning systems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •