Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Pool filter issues when vacuuming

  1. Back To Top    #1

    Pool filter issues when vacuuming

    When vacuuming my pool, everything works fine for about 10 minutes. After that, dirt comes from the return line back into the pool. The sand filter is working to some degree, as when I backflush it, the water is very dirty. It is not sand going into the pool. HELP...
    gresta46001
    21,000 gal IG Vinyl
    Hayward Pro Series Sand Filter
    1 HP 11/2" pump

  2. Back To Top    #2
    frustratedpoolmom's Avatar
    Join Date
    May 2007
    Location
    SWSuburban Chicago, IL
    Posts
    11,963

    Re: Pool filter issues when vacuuming

    You can open up the filter and check to see if the sand is channelled.
    Helpful links: Pool School; CYA/Chlorine Chart
    24' round AG pool, 52" high, Raypak heater; Waterway 2 spd Pump;
    150 Sq ft. Clearwater Cartridge Filter; Former and DISSATISFIED "Pool Frog" owner
    http://www.PerfectlyClearPoolService.com

  3. Back To Top    #3

    Join Date
    Jul 2009
    Location
    Shawnee, Kansas
    Posts
    92

    Re: Pool filter issues when vacuuming

    I have issues like this sometimes when the spider gasket in my multiport valve is not seated properly. I sometimes will get 'waste' water returning into the pool while I am vacuuming which spills dirt back into my pool.
    Matt
    20,000 gallon, sand filter, IG vinyl

  4. Back To Top    #4

    Re: Pool filter issues when vacuuming

    Thanks, I checked the spider gasket, and it needs replaced. That will probably fix the issue.
    gresta46001
    21,000 gal IG Vinyl
    Hayward Pro Series Sand Filter
    1 HP 11/2" pump

  5. Back To Top    #5
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    Location
    SW Indiana
    Posts
    8,617

    Re: Pool filter issues when vacuuming

    Is the filter pressure significantly higher when the dirty water starts returning to the pool? If so, here's a possibility: You start vacuuming with a clean filter and everything works like it should. As the filter gets dirty, the filter pressure rises, and a weak multiport gasket allows dirty water to bypass the filter and return directly to the pool.
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

  6. Back To Top    #6

    Re: Pool filter issues when vacuuming

    my pool has done the same thing all summer. i had to replace the pump and ever since i done that when i vacuum dirty water comes back through the jets. i stop and backwash and start again and it works fine for a while, then it the dirty water comes back through the jets again. how do i check to see if it is a bad multiport, or is this something i have to get a pool guy to come and do?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •