Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Pump losing prime when turned off.

  1. Back To Top    #1

    Join Date
    Apr 2014
    Location
    Oklahoma
    Posts
    71

    Pump losing prime when turned off.

    Having some trouble with my pump basket draining a few minutes after it is turned off. Checked/lubed the basket o-ring and drain plugs, issue persists. I'm fairly certain the leak is past the pump as I can turn a ball-valve that sits between my pump and filter and it stops the basket from draining (as its happening.) No bubbles in pump basket or from returns while operating the pump normally.

    From other threads, my next guess was to replace the spider gasket. I just replaced the top of the multi-port 3 years ago. I would think the gasket would be good for more than 2 seasons right?

    Also, any advice on the leak would be appreciated. Any other avenues I should take before the spider gasket? As for troubleshooting, I have NO check valve, and cannot shut off flow to main drain or skimmers individually.

    Thanks.

  2. Back To Top    #2
    Mod Squad Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    17,322

    Re: Pump losing prime when turned off.

    Since you are able to use that ball valve to isolate air getting into the system from the pressure side, I would be inclined to focus on the multiport valve or perhaps an air bleeder on your filter if you have one. Even though the gasket is new, perhaps it got pinched or something while turning. I believe there's also a small o-ring that seals the multiport handle shaft as well right? Pressure side leaks can be so small that you won't always see water spurting-out when the system is on, but air can seep-in when the system is off. If you have anything else after the pump, I would inspect that closely as well. Let us know how it turns out.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

  3. Back To Top    #3

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,941

    Re: Pump losing prime when turned off.

    I agree with Texas Splash.....somewhere on the pressure side, air is getting sucked in.

    Pump running, can you see ANY water leak anywhere from the base of the pump to the pipes going underground?

    Sometimes, you can turn off the pump (after it's primed) and hear a tiny 'hiss" that might help identify it.

    It's there and will likely be an easy fix......finding it is often the big job.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  4. Back To Top    #4

    Join Date
    Apr 2014
    Location
    Oklahoma
    Posts
    71

    Re: Pump losing prime when turned off.

    No air bleeder valve. I do have 2 small drips, one from the filter drain plug and one from the pressure gauge, however, had those last season and don't recall having the issue.

    When turned off, I do hear a hiss near the backwash pipe (I have a hard-piped line) and lots of gurgling from the multi port.

    I did open it up the multi-port a couple of weeks ago to inspect so will start there for root cause.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •