Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: aqua rite digital read out is blank

  1. Back To Top    #1

    Join Date
    Jun 2015
    Location
    Cary IL
    Posts
    4

    aqua rite digital read out is blank

    I have a aqua rite chlorine generator. I wanted to check my salt level after I opened the pool this week. I turned the system off and then back on to recalibrate the system. When I turned it back on the digital readout started to blank out. I tried again reset the system. On the 3rd try all the lights came on for approx 10 sec, and then went out. I turned the system off and now the power light and the generating light stay on with the system off. Also the digital read out is still blank. Is my circuit board bad? I would order a new one but want to see if anyone else has had this problem before I spend $200

  2. Back To Top    #2

    TFP Guide

    chiefwej's Avatar
    Join Date
    Jun 2011
    Location
    Tucson
    Posts
    3,111

    Re: aqua rite digital read out is blank

    It could just be the contact between the boards. Turn it off, then pull the front display board off and carefully reseat it. It's not uncommon for it to resolve the issue.
    chiefwej
    Tucson, AZ
    16x36 rectangular (19k) Pebble Tec play pool/spa, Pentair Intelliflo VS 011018, Super II 2hp (spa), Aqua Rite T-15 SWG, Pro Grid 60 DE, H400 & Heliocol Solar, Dolphin S-300, fill water w/high CH and TA, 50 ppm borates,TF-100 test kit, Smart Home/Alexa pool control

  3. Back To Top    #3

    Join Date
    Jun 2015
    Location
    Cary IL
    Posts
    4

    Re: aqua rite digital read out is blank

    Thanks I will give it a try

  4. Back To Top    #4

    Join Date
    Jun 2015
    Location
    Cary IL
    Posts
    4

    Re: aqua rite digital read out is blank

    Thanks Chiefwej!
    it worked that was the problem

  5. Back To Top    #5
    appstategrad's Avatar
    Join Date
    Jul 2014
    Location
    Hickory, NC
    Posts
    164

    Re: aqua rite digital read out is blank

    This is a timely post for me as I am having a similar issue with the display, and also giving wrong information (showing I have a different cell, skipping the salt reading and temperature, etc.) My unit is 3 years old...just curious how old yours is lefevr1? Any one have any idea how often these units have to be replaced? I will try this fix tomorrow. Thanks!

    ~ 18.5' x 36.5' inground Grecian pool with vinyl liner
    ~ approximately 23,000 gallons
    ~ AquaRite Salt Water Generator cell size t-9
    ~ 1.5 HP Hayward Pump and Hayward Sand Filter
    ~ TF-100 test kit

  6. Back To Top    #6

    Join Date
    May 2009
    Location
    St. Louis, MO
    Posts
    45

    Re: aqua rite digital read out is blank

    I, too, have this same issue. I see a new display on Amazon, GLX-PCB-DSP, for $84. However, I'll try re-seating the existing one first. It's raining cats and dogs here, may be a few days.
    30,000 galllon, inground, vinyl liner, L-shaped pool
    1.5 hp pump, sand filter, heater, run pump 24/7
    Aquarite salt system
    St. Louis, MO, USA

  7. Back To Top    #7
    appstategrad's Avatar
    Join Date
    Jul 2014
    Location
    Hickory, NC
    Posts
    164

    Re: aqua rite digital read out is blank

    Quote Originally Posted by chiefwej View Post
    It could just be the contact between the boards. Turn it off, then pull the front display board off and carefully reseat it. It's not uncommon for it to resolve the issue.
    I tried this today and it did not work for me. I did notice my GFCI test/reset button was not working. I plan to get this replaced, but in the meantime could this be a cause for the display messing up?

    ~ 18.5' x 36.5' inground Grecian pool with vinyl liner
    ~ approximately 23,000 gallons
    ~ AquaRite Salt Water Generator cell size t-9
    ~ 1.5 HP Hayward Pump and Hayward Sand Filter
    ~ TF-100 test kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •