Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Is this "normal"?

  1. Back To Top    #1

    Join Date
    Jul 2007
    Location
    Katy, TX
    Posts
    188

    Is this "normal"?

    Okay, was not sure where to post this so I apologize if it is not right. We had a pool put in Feb. 2007. Used a good co. that gets alot of business and even people from this board used them. From the top of my head we have had replaced: wireless remote, valves from pool to spa, intellichlor 3 times, mother board to the pool. Now our blower just went out. Luckily I was told our equipment was under a 3 year warranty and thus far everything has been covered except the blower. I was told the blower was only 1 year. My pool co. referred me to another pool co. for the blower (not the same co. that has replaced or dealt with all the other issues) and they called me for the serial number. I gave it to them, off the equipment, and they stated it did not sound right. Anyway, was advised by this co. yesterday that polaris declined it as only one year warranty and then he said " your pool was built in 2003". NO IT WAS NOT! Now I am thinking this blower was old. I have all paperwork from my pool but not a single thing for this blower.

    So here are my questions. First, given how "old" my pool is, is it normal for this much equipment to be relaced? The pool service who comes out to fix the issues told me my file was the biggest of all their clients and stated that I have some bad luck. I have 1 year left on my warranty and am worried what will happen after that?

    Second, is there any way to find out how old the equipment is that was put in? I am uneasy with our blower. Not even sure that it really makes a difference other then why a pool company that appears to keep quite busy would install equipment from 2003 in a 2007 pool. I don't know I am am just trying to figure out if most people are having to replace equipment like I am or did the builder put in old, **** equipment.

    Anyone care to shed some light or your thoughts on the matter? I left a mssg for my pool builder about blower (although why they did not tell me only a one year warranty when I called originally???) and also how concerned I was with the amount of equipment that has had to be replaced in 2 years. Let's see if they call me today ....won't hold my breath! Thanks for any input!!
    ~Andrea

    24,000 IG with spa and 4 ton waterfall. Equipment: Pentair 520 Clean & Clear, Pentair VS+SVRS Intelliflo, Pentair Whisperflo 2 HP, Polairis Cleaner, Intellibrites, Pentair Rainbow 320 in-line Chlorinator, Pentair Easy touch 8 wireless and spa side remote.

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887

    Re: Is this "normal"?

    I can't help with all of your questions, but I assure you that your experience is very unusual. Remotes are the most likely to have problems, and every now and again there will be a bad Intellichlor or motherboard. But going through three Intellichlors is ridiculous, valves almost never fail in the first several years, and the sheer number of problems you are having is exceedingly unusual.

    It sounds to me like you are beyond simple bad luck and there must be some common thread to these problems. The only possibility that occurs to me is bad power. Surges on the power line can damage nearly any kind of electrical equipment. Surges can come from nearby lightning strikes or in rare cases from large industrial electrical equipment on the same neighborhood power feed. It is possible to get a whole house surge protector, which will solve nearly all power line surge problems. Have you had any non-pool electrical equipment fail around the same time you have had problems with your pool equipment?

    I suppose it is also remotely possible that your builder gave you known defective equipment, perhaps parts that got removed from repairs at other locations. But that wouldn't be in their best interest, given that they are providing warranty repairs and is really only a tactic used by the worst of the eBay sellers.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3
    Ohm_Boy's Avatar
    Join Date
    May 2007
    Location
    Orlando, FL
    Posts
    1,344

    Re: Is this "normal"?

    I have seen really strange power problems occur from loose connections, and from poorly grounded electrical systems. Do you see any other odd issues? Go through way too many light bulbs? Any recent TV failures? Appliance controls going out?
    [center:1kpalu48]Helpful Links: Pool School | CYA/Chlorine Chart | Pool Calculator[/center:1kpalu48]

  4. Back To Top    #4

    In the Industry
    budster's Avatar
    Join Date
    Dec 2008
    Location
    Savannah Historic District
    Posts
    272

    Re: Is this "normal"?

    I second JasonLion's remarks about the Intelli-products. If you are having surges, frequent power outages, or new construction in your neighborhood, I'd look there. I'm glad they recognized the warranty.

    In terms of the QT Blower (I assume, rather than the metal Anzen model), I can report that in my area, we have had multiple failures of this product. As to the age of the blower, Polaris has the final say, based upon the serial number, however, if you can produce some proof of installation date to them, you might get results. Could it be an old blower, that had been sitting on a shelf somewhere? Always possible, but not common. If you have a Polaris cleaner, have them check the SN on it, too. Good luck.
    http://www.swimmingpool.com/

    "Leave the gun...take the cannolis"

  5. Back To Top    #5

    Join Date
    Jul 2007
    Location
    Katy, TX
    Posts
    188

    Re: Is this "normal"?

    Thanks everyone. As I thought the PB never returned my call. Other then a very old TV that went out - nothing else. No loss of power. We do live in a neighborhood which is still growing but nothing within blocks of me. No lights have gone out.

    Can I call polaris and give them the serial numbers to get info.? Will they provide that to the pool owner?

    I really appreciate all the info. Thanks all!!!
    ~Andrea

    24,000 IG with spa and 4 ton waterfall. Equipment: Pentair 520 Clean & Clear, Pentair VS+SVRS Intelliflo, Pentair Whisperflo 2 HP, Polairis Cleaner, Intellibrites, Pentair Rainbow 320 in-line Chlorinator, Pentair Easy touch 8 wireless and spa side remote.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •