Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: pentair dynamo pump issues

  1. Back To Top    #1

    Join Date
    Jun 2014
    Location
    masury,ohio
    Posts
    2

    pentair dynamo pump issues

    Hello new to the forum here and looking for some advice. My 1.5hp dynamo pump started humming the other day. I have taken it apart and found this motor has no capacitor which would have been the easy fix. I can get the motor to start with impeller off but have to help the motor by spinning the shaft. although there is something wrong there it would be fine with me if that's all i had to do. My real issue comes when i put the impeller back on. It screws too tight against the diffuser causing it to rub. I am wondering if it could be the spring loaded seal is worn down? The motor, impeller,and diffuser seem to be in very good condition as well as the seal but i don't know Any ideas are greatly appreciated.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,331

    Re: pentair dynamo pump issues

    It would be odd if it were the seal but it certainly could bind the impeller if there was some buildup.

    The problem of the motor not starting by itself is probably the centrifugal switch. It's located near the back of the motor around the shaft. Cleaning up the contacts will probably solve that problem.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Join Date
    Jun 2014
    Location
    masury,ohio
    Posts
    2

    Re: pentair dynamo pump issues

    thank you very much for your quick response. I did clean up the inside and switch and it kicks on after a slow startup of about 2 seconds. I installed a new seal and still have the problem of the impeller being too tight to diffuser...when i tighten down impeller the motor is way too tight when turning shaft from rear of motor... Please help me before i rip my hair out!!!

  4. Back To Top    #4
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,331

    Re: pentair dynamo pump issues

    Does the back of the impeller look flared out or does the threaded insert look worn? How about the shoulder on the motor shaft? Is it worn?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •