Worried there's a leak in the winter cover - First time opening

MassNerd

LifeTime Supporter
Apr 27, 2013
174
Central Massachusetts
I've been pumping water off the solid plastic cover in preparation for opening. I noticed the water on top of the cover was 2ft+ deep in the center of the cover. Not quite as deep on the the sides. I thought the center would come up as I pumped up water. I've pumped maybe a foot off. I feel like the water level on top of the edges is getting close to where I drained to when closing, but the center hasn't gotten much shallower. It may still be 1.5 feet deep.

So now I'm worried something is wrong. Either the pool is leaking (which it didn't all summer and fall) or perhaps there's a hole somewhere in the cover (I couldn't find one that was obvious, but it could be under leaves) and water from the pool is leaking onto the top of the cover.

What do you guys think? Is this normal and I should keep pumping? Or should I immediately stop pumping water out and handle this cover removal in a different way?

Photos:
 

Attachments

MassNerd

LifeTime Supporter
Apr 27, 2013
174
Central Massachusetts
Update: I spoke with my PB and he explained that I likely did lose water due to displacement. We had a lot of precipitation this winter (12-18" liquid) and the water could have been pushed up high enough in the skimmer to leak into the ground. He recommended pumping the water from the cover into the pool as it hasn't been warm enough for anything to grow in it. I could optionally chlorinate the water on the cover for a couple days. I'll probably do that.