Will a freeze damage a cartridge filter?

shaffer1

New member
Jul 15, 2007
3
#1
I have a Pentair Clean & Clear Plus 320 filter which worked fine until we had a freeze (13 degrees) last winter. I suspected the cartridges may have been damaged so I replaced them but it still appears that something is wrong. I kust returned from a trip and found the pool water itself to be clear but lots of what appears to be dead algae on the bottom. When I vacumn it up I can see dirty water coming back out through the return lines. I have checked the bottom mamifold and the top assembly and can not find any cracks or breaks.
I do not want to continue replacing parts that may not need to be replaced.
Any ideas?????
 

JasonLion

TFP Expert
Platinum Supporter
LifeTime Supporter
May 7, 2007
37,880
Silver Spring, MD
#3
Does your filter pressure read normally, ie what you are used to seeing? Usually freeze damage causes obvious leaks, but there are still quite a few other possibilities. The main valve might have been damaged and could be allowing water to go around the filter.
 
OP
OP
S

shaffer1

New member
Jul 15, 2007
3
#4
JasonLion said:
Does your filter pressure read normally, ie what you are used to seeing? Usually freeze damage causes obvious leaks, but there are still quite a few other possibilities. The main valve might have been damaged and could be allowing water to go around the filter.
No visible exterior leaks. Pressure reads at 18 psi which appears to be normal for a clean set of cartidges. No valves on return side since there is no spa or return line control.
 

buddywiser

LifeTime Supporter
May 23, 2007
98
Morgantown, WV
#5
I had dirt coming out of my jets when I vacuumed and found that the manifold was not sitting properly in the return hole, so I was just moving dirty water around for about a 2 weeks. :oops: My water got pretty cloudy and fixing this cleared it up in a day.
 
OP
OP
S

shaffer1

New member
Jul 15, 2007
3
#6
buddywiser said:
I had dirt coming out of my jets when I vacuumed and found that the manifold was not sitting properly in the return hole, so I was just moving dirty water around for about a 2 weeks. :oops: My water got pretty cloudy and fixing this cleared it up in a day.

Thanks, I will check that out.
Steve