white stuff inside SWG

imcj

Well-known member
May 18, 2010
182
I can't remember what you call the part, but when you look through the clear tube there is white (calcium?) buildup inside on the far right and a little big of green on the big copper looking things that you can pull out. (well, nobody can say that I'm too technical can they? :-D ) I saw muriatic acid recommended on this site a long time ago, and I was able to clear that out before. Would somebody remind me if it was straight ma, or is it 1/2 pool water and 1/2 muriatic acid, or...? I tried the vinegar, but it sat for an hour and didn't do anything.

I need to do something because my FC is dropping because the SWG just beeps and reads "low salt" like it did before. Thanks for your help.
 

Strannik

TFP Expert
LifeTime Supporter
Jul 24, 2007
874
Brisbane, Australia
it should be in your owner's manual

different manufacturers recommend different concentrations.

i normally use pure ma, as it gets the job done quicker. general recommendation is 5-8 parts of water to 1 part of acid or so.
 

imcj

Well-known member
May 18, 2010
182
My owner's manual doesn't recommend ma at all, just vinegar, but like you said it gets the job done. Thanks.
 

imcj

Well-known member
May 18, 2010
182
Well, I used the ma and the white stuff is gone from the cells I guess is what you call them. The main tube that you can see through has a little white on it, but I don't know what that's about. Anyway, I keep getting the low salt "91" reading. Last time it did this I just cleaned it and all was well. I even added some salt just in case, although I'm pretty sure it's not low. I'm not positive because I ran out of salt strips. I'd sure like a more accurate way to measure salt.

Wait a minute. I just remembered we just had some very heavy rain last week. Would that affect this?
 
Thread starter Other Threads of Interest Forum Replies Date
CasaBlanca Under Construction 2
B Salt Water Chlorine Generators (SWG) 1
N Everything Else 7

Other Threads of Interest