Whisperflo WF-12 3hp spark then throws breaker

Aug 28, 2020
5
Vancouver
The pump threw my breaker when I turned it on so re-tried this a couple more times with the same result. I checked the capacitor for damage but nothing apparent and i used a multi-meter to check for continuity and seems to be intact. I torn out the pump and pulled the housing off down to the impeller and the impeller turn in both directions with no resistance to speak of. I re-connected it to see if there was any difference without the diffuser and basket etc. it sparked from the motor through the venting and then threw the breaker within a second or two. Greatly appreciate any assistance.
 
Aug 28, 2020
5
Vancouver
Are these motors "repairable"? There's a ton of info on how to replace them which is fine but I can't find any info on repairing them? I assume if there's a short that should be a fairly simple fix? Cheers.
 
Aug 28, 2020
5
Vancouver
How old is the pump?

Do you need 3 hp?
Pump is old.... real old. Bought the house in 1988 and it was installed then. That said it was really only used for a couple of years then and mothballed until last year. Used it for a few months last year and a couple of months this year prior to this problem in early August. I have two 3HP pumps that run a swim spa and a 1hp that circulates / filters / heats. Do I need 3hp.... I don't know but that's what was installed and I'm thinking it's due to the swim spa aspect of it. The whole thing is really just a very large hot tub for the most part lol.
 
Aug 28, 2020
5
Vancouver
So is there a place I can get a replacement winding? I can't find anything out there other than for stators. everything else seems fine as far as bearings seals capacitor impeller difuser etc etc.