Weird flow switch LED issue

moyer02

LifeTime Supporter
Oct 11, 2010
73
Pensacola, FL
For the last four days, when my Pentair IC40 system starts up, the salt level lights flash green and red and the flow glows red. About four or five hours later, the salt light glows green but the flow LED goes off (not red, just off). The cell light also glows green when it's active like it's supposed to. My salt level is good (about 3400). PH is 7.2, FC is 4.5 and except for low TA (50) and low CYA (40) the chemistry checked out. So far I've:
Cleaned the Salt Cell;
Backwashed and rinsed the sand filter;
Retested salt and other variables, ok.
I'm thinking it's a bad flow switch and I've ordered a replacement.

One other weird thing happening: When I press and hold the "more button" to determine how much cell life is left, the lights scroll as expected, and then the 20% and 60% LED lights stay on. The cell is about four years old and I've always had it set at 20% output without issues. Also, if I try and increase the output from 20% to 40%, the 20% 60% and 100% lights go on and I have to depress the less button to get back to the 20% output. Looks like I don't have an option to run it at 40%.

Thoughts? And thanks.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
13,986
Bedford, TX
Bill,

If the flow light goes off, not green or red, then that has to be a cell problem.. If the "Cell" light is still green when the flow light is off, then it has to be a light or light driver issue as the cell itself still thinks the flow is good or the Cell light would be off..

If you have never replaced the flow switch it would be a good investment compared to a new cell.. It will not fix the "off" flow light but it has a good chance of fixing the intermittent red/green flow light..

Thanks,

Jim R.
 

moyer02

LifeTime Supporter
Oct 11, 2010
73
Pensacola, FL
Bill,

If the flow light goes off, not green or red, then that has to be a cell problem.. If the "Cell" light is still green when the flow light is off, then it has to be a light or light driver issue as the cell itself still thinks the flow is good or the Cell light would be off..

If you have never replaced the flow switch it would be a good investment compared to a new cell.. It will not fix the "off" flow light but it has a good chance of fixing the intermittent red/green flow light..

Thanks,

Jim R.
Thanks Jim. What you said makes sense, especially since the cell is about four years old. I'll change out the flow switch when I get it and see what happens.
 

moyer02

LifeTime Supporter
Oct 11, 2010
73
Pensacola, FL
Thanks Jim. What you said makes sense, especially since the cell is about four years old. I'll change out the flow switch when I get it and see what happens.
Well, got around to replacing the flow switch today. Unfortunately none of the symptoms went away. Guess it's time for a new salt cell.