Water not flowing after cleaning cartridge filters. Seems like Pump priming issue

sandeepkc

Member
Jul 25, 2020
7
Cumming, GA
Pump issue: cleaned my CV460 filters and put the assembly back. As suggested by the instructions on the filter, kept the pressure valve open. Started the Jandy aqua link system back up but it seems either the pump won't flow the water or perhaps I need to wait longer and watch the water fill back in the filter.. did not want to blow the pump so checking here before doing next steps.. pics and video of my set up uploaded .

here is a video of how the pump sounds.

Also, would like to understand the relevance of the black valve towards the front of the pump (looks like it is setting the direction of water coming in from the main drain or skimmers). Is that set up right?

Additional, what is the relevance of the check valve
 

Attachments

HermanTX

Gold Supporter
May 20, 2020
666
Katy TX
Sometimes its good to fill the pump basket with water to help prime the pump. I normally have my inlet valve turned to main drain as that has more hydrostatic pressure on it to allow pump to create a suction. You can then move the inlet valve after the pump is fully primed to skimmer or both.
Keeping your air valve on your filter open is fine as it lets air escape as the filter fills with water.
Your video did not seem to load.
You do not want to let your pump to run a longtime without water as that will over heat it. Just add water to the pump basket. Tighten the lid and then turn pump on. Ensure you have inlet flow valve turned to main drain (my preference) or to skimmer.
 

HermanTX

Gold Supporter
May 20, 2020
666
Katy TX
Video link.
OK - your pump sounds like any other without water. That check valve prevents back flow to your pool - actually it can be helpful by filling your pump basket with water it will actually hold the water to help prime the pump. This assumes the check valve is operational - to allow flow from the pool.
 

sandeepkc

Member
Jul 25, 2020
7
Cumming, GA
OK - your pump sounds like any other without water. That check valve prevents back flow to your pool - actually it can be helpful by filling your pump basket with water it will actually hold the water to help prime the pump. This assumes the check valve is operational - to allow flow from the pool.
I tried priming it by putting water in the skimmer basket and trying all the options - inlet valve to both, skimmer and main drain. As soon as I start the pump, waters get sucked out and then the same noise as in the video appears back. Also, went back to the pool skimmers and checked if the flaps were not blocking water flow. Any others tips to find out the cause for no water flow?