Water line to Raypak pool heater burst last night—now pool heater won't ignite

coolinthepool

Well-known member
May 8, 2019
64
Fishers, IN
Updated below: Heater is back on.

Blah, this is a bummer. Woke up this morning and went outside to find my pool drained to the skimmer and the area around the heater soaked. The water line to the heater was detached. So however many thousands of gallons of water were ejected directly into the side of my propane Raypak 336A heater. I filled the pool back up and got the water running, started the heater back up, and it won't ignite. It gives a "no pilot sensed ignition lockout" error after attempting for a minute. The pilot light does light and is on as soon as it does its first spark to light. But it doesn't appear to sense that it's lit. I'm guessing a logic board may have gotten soaked and is trashed.

So far, I've tried:
  • unplugging and plugging back in
  • shutting off gas supply and turning back on
  • verifying that propane was present (tank is full and pilot light is lit)
  • taking an air blower and blowing out inside of heater to make sure no debris is in the way or that water isn't present

Thoughts are welcome, I'm looking through the manual now.

Looks like since I have a pilot light and it's still not lighting, then I might have a busted PC board.


Update: I went back out to the unit and made sure the electrical lines to the main ignition turnoff were secure and clean (just removed and blew them and put them back on) and after doing so, it fired up. I'm going to leave it running for the day and then I'll check it again this evening. Obviously the next step is addressing the pipe that broke.
 
Last edited: