was this done incorrectly? (pics)

xfilegirl

Bronze Supporter
Jun 15, 2017
35
Bellerose/NY
I was looking at some client photos of the same pool I have (21'X54" Saltwater LX Round Pool) and I noticed that the service panel where the skimmer box goes was a tan color. Mine is blue. It always had this little tear line from where the return hole was made but i just thought that was a scratch that happened during the return install. I thought nothing of the blue colored panel until today I noticed what looks like water discoloration "under" that color towards the bottom of the pool. Now to me it looks like that was a protective film that the installers should have removed when the put the pool up. What do i do with it now?! I emailed the pool company and I'm waiting to hear back but does this look like that to you as well?
 

Attachments

Shirker

Well-known member
Jul 2, 2014
380
Athens, GA - USA
It does look like a film in your pictures. Like what comes on new appliances to protect them during shipping/install. My last pool had a single stainless steel panel where the skimmer and return were but I don't recall it having a film. If that is what it is, it is probably safe to peel off. Maybe someone else has seen this before?
 

xfilegirl

Bronze Supporter
Jun 15, 2017
35
Bellerose/NY
right...but the pool is dug like a foot into the ground. So i won't be able to access the film that is behind the dirt. I'm afraid of the water seepage (that can't dry itself out) doing damage to the wall over time.
 

xfilegirl

Bronze Supporter
Jun 15, 2017
35
Bellerose/NY
Pool company called me back. Said it's common to leave the film on sometimes and that it will cause no damage...the discoloration is just that...just discoloration and not damage. He said I could pull it off up to the dirt line if i prefer. But i think i'll just leave it as is.