Warrior impeller overload error won't go away and I cleaned the impeller

adamfrey

Member
Mar 31, 2020
18
atlanta
Hello great gurus,

Got a new Warrior SI. Cleaned like a charm for a week....impeller got some stuff in it. I cleaned it. Hit reset robot but it still says impeller overload... I have called into Pentair but wasn't sure if there is something that I am missing? I can manually drive it all over the pool but won't run its auto cycle.
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2014
33,033
Texas, San Antonio/Marion, South-Central Area
Pool Size
17888
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
Hello Adam! :wave: I don't have a Warrior cleaner, but see that no one has replied to your post after over a week. Figured it was time to follow-up to see if you still need help to try and get this thread some visibility. Post back as much as needed.
 

Newdude

Gold Supporter
TFP Guide
Jun 16, 2019
10,402
NY
Hey Adam !! Paging @IceShadow because IIRC he had a similar overload that was an electrical issue masked as an impeller issue. These fancy electronics can only guess so much. I hope he has ideas for you. :)
 

IceShadow

Gold Supporter
TFP Guide
Jun 8, 2019
2,612
Milwaukee, WI
Pool Size
20000
Surface
Vinyl
Chlorine
Liquid Chlorine
My main solution was contacting the manufacturer for a warranty repair. That should be applicable here I would think!
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.