Very fine dirt in pool

s2k4cobra

New member
Aug 16, 2019
4
Abilene Tx
We had our Pentair 1hp Superflo pump crack from the Texas winter storm and I replaced the pump with a Superflo 1.5hp pump. Ever since then I have very fine dirt in the pool. I have vacuumed twice and it always returns. Granted I didn't vacuum to waste because I thought the dirt was from high winds which we get in West Texas. My question would be is my pump too big for the Triton II TR60 sand filter(replaced last summer), maybe cracked laterals, need to vacuum to waste and see or my problem is something else I'm scratching my head on this one.
 

Attachments

  • dd.jpg
    dd.jpg
    47.3 KB · Views: 23
  • ff.jpg
    ff.jpg
    42.6 KB · Views: 22
  • gg.jpg
    gg.jpg
    42 KB · Views: 22

Newdude

Gold Supporter
TFP Guide
Jun 16, 2019
6,830
NY
How did you get the 120 CYA ? Over 100 needs to use diluted pool water with tap water until you get a reading under 100 and multiply by the parts used. 2 parts tap water and 1 part pool / R-0013 mix is times 3 for example.
 

s2k4cobra

New member
Aug 16, 2019
4
Abilene Tx
Here is what I'm doing now. I have vacuumed to waste and draining my pool half way on a 25000 gallon pool. I will add new water and balance.
 

s2k4cobra

New member
Aug 16, 2019
4
Abilene Tx
Update.... I drained my pool after vacuuming twice to waste and filled it back up. I have balanced everything and now my CYA is at 40. I don't have the fine sand/dirt looking stuff and I wonder what will happen when I do a backwash and rinse.. The pool looks good as of now.