Vacless SVRS leaking

tim_pool_newbie

Bronze Supporter
LifeTime Supporter
Oct 6, 2009
173
Nazareth, PA
Hi all,

I've been noticing air blowing into the pool via the returns, and after checking all the usual suspects - clogged skimmers, pump basket, loose plumbing connections, etc., I feel like the Vacless SVRS (Model: SVRS10ADJ) may be the culprit. Referring to the attached pics of the device, I feel like the small button in the center is usually pressed up through the top, but I see it is currently depressed. Does this mean the device has been triggered and has not yet reset? Even when the pump is off it does not change.

I've read on the Vacless website about tightening the spring or perhaps changing an O-ring, but am curious if anyone else has experience with any of this. I did unscrew the top and turn the top clockwise a few holes (as instructed in troubleshooting docs) but it's had no impact. Am I on the right track?
 

Attachments

  • IMG_2347.jpg
    IMG_2347.jpg
    443.5 KB · Views: 3
  • IMG_2348.jpg
    IMG_2348.jpg
    379.8 KB · Views: 3

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
47,266
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Sorry you are not getting any responses. To be honest, have never seen anything like that!

Let's hope some other members can help out.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
33,514
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Unscrew the Vacless from the pump drain port and put a normal drain plug in and see if your air problem is fixed.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread