Troubleshooting Red Flow Light in Pentair Intellichlor IC40

jwigginton

Member
Jan 11, 2017
6
Florida
Hello,

I have an IC40 and recently the FLOW light started turning on solid RED and does not go to green. I've done the following:

1. Cleaned the cells - still RED flow light
2. Cleaned filter basket
3. Removed the Pool cartridge filter to see if that could be impacting flow - still RED flow light
4. Shorted the flow switch - connecting Red and Black wires coming from the unit together - still RED flow light
5. Ordered a new flow switch just in case- connected - still RED flow light.

If I am bypassing the flow switch (#4) and its still RED, is there something wrong with the unit or circuit board? Any other suggestions, I'm at a loss.

Also - the startup lights - blinking between good and low salt (green and red) - stays blinking for a really long time, maybe 10+ minutes. Eventually salt level indicator does go to solid Green, but takes

Thanks
Josh
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
21,164
Bedford, TX
Josh,,

From what you describe the cell is bad.. How bad depends.. If the problem is just the LED and all the other lights work normally, and the Cell light comes on when the cell is making chlorine, then it is a problem you can live with.. On the other hand, if it is the circuit that determines whether you have good flow or not is bad, then the cell will never make chlorine.

I would un-short the wires and see if the cell light comes on when the cell is supposed to be making chlorine. If you set the output to 100% the Cell light will stay on most of the time.

Thanks,

Jim R.
 

jwigginton

Member
Jan 11, 2017
6
Florida
Jim,

Thanks for the info. Interesting - so i did have it rewired back to normal, and the flow light was RED as usual and cell light OFF. I turned it up to 100, and the flow light turned GREEN and Cell light came on Green. This is a good thing, i think.
So the flow light is just RED when the cell is not ON? Does this mean it should be working somewhat OK, just have a funky Flow light/circuit? Any clue on that?

I checked the cell life and its at 60%.

Thanks
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
21,164
Bedford, TX
J,

The flow light should only come on and off based on whether you have good flow or not.. Something is wrong with your cell.

In theory, as long as the Cell light is working the cell should be making chlorine..

Turning up the % value should not have anything to do with the flow light..

I guess my point is, that something is wrong, but as long as the cell light comes on, you should be able to use the cell..

Since it is so odd, you will have to determine if that will work for you or not.

Thanks,

Jim R.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.