Trouble Reconnecting Indoor IntelliTouch Controller

WBT81

New member
Dec 4, 2019
1
Millbrae, CA
We have an IntelliTouch i5 system with an indoor controller. It had been working fine since we moved into the house a few years ago, but as part of renovations we had to disconnect and relocate the indoor control unit. When I went to reconnect the controller, the display/menu looks like it did before being disconnected by the controller is having trouble communicating with the system. When I try to enter the programs I get an error message regarding failure to get data and the date time is stuck at 1/1 12:00AM. I tried connecting the controller directly to the system COM port with a short wire and got the same result. I can manually turn all of the system components using the buttons on the system control panel, but can't figure out how to get the indoor controller to work again. I tried Pentair support, but didn't have any additional ideas and I am currently in the process of looking for a new pool service.

Not sure if I managed to fry the indoor controller (or system control) when disconnecting/reconnecting or if I am missing a step, but would really appreciate any assistance or ideas on how to diagnose the issue.

Thanks,
William
 

ogdento

Bronze Supporter
Mar 30, 2015
398
Chico, CA
Hey William,
When you disconnected and moved the wires, was the power ON to the outdoor controller? (don't feel bad if it was - I've done this myself!) If the wires were moved with the outdoor controller powered up, the comm port on your outdoor controller is likely dead.
The comm port on these things is an rs485 port and if the D+/D- lines (green/yellow) touch the supply wires (red/black), the comm port gets smoked.