This year it's a pressure problem, pump basket won't fill all the way.

DaveBinWL

Member
Sep 7, 2013
23
White Lake, Michigan
I've done searches and it seems like my issue is decently common. I know I need to follow protocol and walk through the necessary steps to see if I have any air leaks. But I have one thing that may be a clue? Not sure, that's why I figured I'd post and see if anyone had insight.

Everything seems to be up and going just fine except the pump basket won't fill all the way to the top, it's almost to the top but not quite. Water seems to be coming in and must be going out but when I check the skimmers and returns it seems like there's no water coming or going.

One thing that helps is when I open the pressure valve on the filter then it starts to get water moving. I can see it flow in the pump, I checked the skimmers and can see water actively flowing there too. Is that any indicator of something I'm missing here? Water is spewing fully out of the valve at this point as well. Once I shut it off the flow goes back to seeming non-existent.
 

DaveBinWL

Member
Sep 7, 2013
23
White Lake, Michigan
I guess I can check it again. What exactly would I be looking for? At the end of each season I fully clean it and put it back together so it's ready for opening the following. I did take it apart today and inspected before I sealed it up, normal like always as far as the filter grids are concerned.

There is no DE in the filter yet this season.
 

DaveBinWL

Member
Sep 7, 2013
23
White Lake, Michigan
Turned out to be something dumb, just as I suspected... me. There was a plug inside the filter either I had forgotten about or the new pool closer put in that hadn't been plugged before. Anyway, the advice to pull apart the filter and re-check led me to it so I'm glad I posted here for some thoughts before going through a tedious air leak inspection. Thanks again guys!