tab chlorinator not working

macgas

Active member
Jul 29, 2010
38
Houston,TX
I have recently switched to BBB method but 3 weeks ago the feeder was half full. I turned it all the way up and expected all of the tabs to dissolve. I checked it today and I see no appreciable change. Any ideas?
 

JohnT

Admin
Mod Squad
TFP Expert
Apr 4, 2007
9,535
SW Indiana
Some are prone to deposits that reduce the water flow to almost nothing. What model do you have?
 

poolgirl22

Platinum Supporter
LifeTime Supporter
Apr 14, 2010
595
Stephens City, VA
Your dial could need a new o-ring. Mine used to do that when the ring was bad so I never really knew where it was dialed into in terms of flow. Take the dial out if you can, take the existing ring out and go to Lowes and get some new ones to keep on hand. Also, mine used to get a build up inside over time that I'd have to scrape off.

Better yet, you could use this as an excuse to de-plumb the chlorinator and either manually add bleach or liquid chlorine (or the Liquidator of course!!!). If you have been feeding your pool a steady diet of pucks for an extended time, your CYA levels may be rather high considering your location and you likely don't drain down your pool in winter.

Now the true question is....
If you haven't added any measurable chlorine to the pool in 3 weeks you could be in for a not so fun time of cloudiness or algae bloom. Please take a full set of test results and post them so we can get an idea where you stand that way and advise you further.

(edited: John was faster and more concise then me...)
 

macgas

Active member
Jul 29, 2010
38
Houston,TX
Oh the pool is great, numbers are fine. I just don't know what to do with these pucks that are not dissolving. I add liquid chlorine everyday.
I'll try looking at the o rings, thanks.