SWCG previously installed but currently disabled

giant_bronut

Active member
Mar 16, 2021
44
Austin, TX
Pool Size
20000
Surface
Plaster
Chlorine
Liquid Chlorine
Hi TFP!
We had moved into the house with an in-ground pool that was being maintained by chlorine pucks. I have since kicked that to the curb and going with liquid chlorine. However when we did the pool inspection it was reported that the pool was configured with a SWCG but there is no power and the prior owners never used it. I think it hasn’t been used for 8 years.

I would love to bring it back from hibernation and wanted to get your thoughts on whether I should call a pool company or if this can be a DIY project. I haven’t taken pics of the main circuit board but here are some pics to get started. Is this as simple as changing out the fuse and ordering a replacement salt cell? Also I am very new to pool maintenance!
 

Attachments

  • C2CA283E-D515-4300-8E90-4B0E38128957.jpeg
    C2CA283E-D515-4300-8E90-4B0E38128957.jpeg
    486.2 KB · Views: 103
  • 1DEE941F-12CD-445A-88F4-51C67FC0EC02.jpeg
    1DEE941F-12CD-445A-88F4-51C67FC0EC02.jpeg
    601.8 KB · Views: 39
  • AC49E4DE-1AC8-47D2-B53A-1D0E9B48A757.jpeg
    AC49E4DE-1AC8-47D2-B53A-1D0E9B48A757.jpeg
    307.5 KB · Views: 38

JamesW

TFP Expert
Mar 2, 2011
23,939
The box is from 2005.

What are the first seven characters of the cell serial number?

Might as well get it going.

Start it up and see what works.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
24,720
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Open up the Aqualogic and post pics of the front and back of the boards. Those boards can burn out components and solder joints. Let's see what condition your board is.

What do the panel diagnostics show?
  • Report all readings when you..
    • Go to the diagnostic screen, note the readings and then press the + button to reverse the polarity.
    • When the new numbers appear, see what they are.
    • Then, press + again and note the new readings.
  • What are the first seven characters of the cell and box serial numbers?
  • What is the actual salinity and how are you measuring it?


@JamesW
 
  • Like
Reactions: giant_bronut

JamesW

TFP Expert
Mar 2, 2011
23,939
I wouldn't get into the main circuit board just yet.

Let's get the chlorinator enabled and check the diagnostic readings.

Check the salinity with a K-1766 salt test kit.
 

JamesW

TFP Expert
Mar 2, 2011
23,939
Ok, the cell is also from 2005.

They only last about 5 to 7 years. So, it's probably bad.

Enable the chlorinator and check the diagnostic readings.

Get the salinity to 3,200 ppm.
 

giant_bronut

Active member
Mar 16, 2021
44
Austin, TX
Pool Size
20000
Surface
Plaster
Chlorine
Liquid Chlorine
I wouldn't get into the main circuit board just yet.

Let's get the chlorinator enabled and check the diagnostic readings.

Check the salinity with a K-1766 salt test kit.
I got it enabled using the video above but it shows “check system”.
Diagnostics:
Chlorinator off no flow
Instant salt chlorinator off
Flow switch no flow
 

JamesW

TFP Expert
Mar 2, 2011
23,939
c2ca283e-d515-4300-8e90-4b0e38128957-jpeg.317178

The flow switch is right before the cell. There should be a wire from the flow switch to the box and plugged into the box.

Maybe the wire is not plugged in or maybe the flow switch is bad.

Is the flow actually good when it's reporting no flow?

 

Enjoying this content?

Support TFP with a donation.

Give Support

giant_bronut

Active member
Mar 16, 2021
44
Austin, TX
Pool Size
20000
Surface
Plaster
Chlorine
Liquid Chlorine
I imagine that the Cable Flow Switch and the Salt Cell have both gone bad at this point. The salinity was 0ppm at this point as the Salt Cell was disabled and the flow sensor is not operational. I'll post pics of the front and back of the board. It seems I'll have to order a replacement T-Cell 15 and the flow switch. Thanks for the links! I won't order the parts right away as I want to do some research on this further.
 

giant_bronut

Active member
Mar 16, 2021
44
Austin, TX
Pool Size
20000
Surface
Plaster
Chlorine
Liquid Chlorine
Hi All,

I had the Flow Switch and the Salt Cell replaced (thank you home warranty!). We had the salt cell replaced with a T-Cell-940. I purchased K-1766 and tested the salt. I haven't added salt yet to the pool as I wanted to share my current readings and the diagnostics with you all to understand the next steps:

I'm still using LC (10%) until I'm ready to enable the salt cell.

FC - 9.0 ppm
CC - 0 ppm
pH - 7.4
TA - 90 ppm
CYA - 60
CH - 650 ppm
Salt - 1800 ppm

Diagnostics when enabling the salt cell:
Flow is working

Voltage/Ampere reading:
0.00 V
0.00 A
0000 ppm

Questions:
1. I know my CH is high as the water balance for swgs states to adjust CH to 350ppm. Water is expensive here so I don't want to drain and refill. Can I proceed with SWCG with CH at 650ppm?
2. Will the Voltage/Ampere reading change once I add salt and it identifies that there is salt present?
3. Any advice/input you can share before I proceed to move ahead with adding salt and enabling the SWCG?
4. Shall I add stabilizer to get my CYA up to 70 after adding salt?
 

JamesW

TFP Expert
Mar 2, 2011
23,939
Go to the diagnostic readings and press the + button to make it reverse polarity and see what the diagnostic readings are.
 

giant_bronut

Active member
Mar 16, 2021
44
Austin, TX
Pool Size
20000
Surface
Plaster
Chlorine
Liquid Chlorine
Go to the diagnostic readings and press the + button to make it reverse polarity and see what the diagnostic readings are.
I did that as well and the readings were the same just negative:
-0.00 V
-0.00 A
0000 ppm
 

giant_bronut

Active member
Mar 16, 2021
44
Austin, TX
Pool Size
20000
Surface
Plaster
Chlorine
Liquid Chlorine
To an extent, yes, we went through turning the pump off when the chlorinator was enabled and the diagnostics showed "no flow" as the pump was not on. Once we turned it on that error went away. We checked for leaks and there were none. When the installer looked at the old SWCG, there was no calcium deposit indicating that it was hardly used. He replaced the flow sensor. I think that was about all he could tell me. He said to research how to "reset" the controller if needed.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
24,720
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
1. I know my CH is high as the water balance for swgs states to adjust CH to 350ppm. Water is expensive here so I don't want to drain and refill. Can I proceed with SWCG with CH at 650ppm?

You can proceed. You may get scale buildup on the cell plates.

2. Will the Voltage/Ampere reading change once I add salt and it identifies that there is salt present?

I think you have a problem with the board. Read Hayward Aquarite SWG - Further Reading


3. Any advice/input you can share before I proceed to move ahead with adding salt and enabling the SWCG?

Pull the main board and examine the thermisitor and the solder joints on the back of the board.

4. Shall I add stabilizer to get my CYA up to 70 after adding salt?

No, CYA 60 is fine. Wait to add CYA until you get your SWG running.
 

JamesW

TFP Expert
Mar 2, 2011
23,939
Who was the service person?

Were they not qualified to diagnose and service the system?

If you have a warranty company paying for repairs, tell them that it's not working and to send out someone who knows what they're doing.
 

giant_bronut

Active member
Mar 16, 2021
44
Austin, TX
Pool Size
20000
Surface
Plaster
Chlorine
Liquid Chlorine
Service Person - Aqua King Pool & Spa LLC

I didn't have the salt test kit by the time the service company came so I didn't have a reading of the salinity level to show them that the salt level being displayed via the controller is not accurate. They were probably in a rush to get out since they told me to reset the configuration. I'll contact the service company that installed the salt cell and have them come diagnose the system.
 

Enjoying this content?

Support TFP with a donation.

Give Support