still cloudy water - kinda white looking

Sep 2, 2007
20
Columbia, TN
#1
Ok, I am hoping someone might be able to help ;)

Last year I found you guys - and got my pool finally open for the kids in Aug! lol
(after the pool companies stole from me for all summer)

Anyway - but when the pump ran, there was like white flaky stuff coming out? Just pool would be clean, and next day - 1/2 the pool would have kinda white cloudy stuff.

So, many said maybe my filter needed to be cleaned.

We ended up closing the pool the next week - so did not deal with it -

This year, I finally got a friend to help me change out the sand in the sand filter -

and we got it a PRETTY blue ;)

But each day - once again - I vacuum, and scoop with the net, and looks great -

the next day more white stuff again????

ANY ideas????

Once again - it is July, and my kids are upset - ;(

I was HOPING to not have to REPLACE my filter - as several people told me I should not have to - (it is 5 yrs old) as long as I changed out the sand on it good.

All my ph and other stats are good.

TIA
 
Sep 2, 2007
20
Columbia, TN
#3
RE: pool results - I do NOT have the huge test result thing to order on here yet - doing that this week.

I have the pool thing with the red/yellow bottles - that does the PH, Chlorine and Bromine - and all are good, and in the proper ranges.

I almost 1/2way think that the white stuff may be sand spitting back into the pool from the filter? Could that be possible? and if so, is there something on the filter to fix that - or does it have to be replaced?

SWG (salt water chlorine generator) - no - not sure what that is? I got all the stuff from here for the bleach, borax and baking soda......and so far that has worked well. It is normal water in our pool, not salt water - does that make a difference or should we think of getting that?
 

frustratedpoolmom

TFP Expert
LifeTime Supporter
In The Industry
May 20, 2007
12,177
SWSuburban Chicago, IL
#4
lauriedelk said:
RE: pool results - I do NOT have the huge test result thing to order on here yet - doing that this week.

I have the pool thing with the red/yellow bottles - that does the PH, Chlorine and Bromine - and all are good, and in the proper ranges.

I almost 1/2way think that the white stuff may be sand spitting back into the pool from the filter? Could that be possible? and if so, is there something on the filter to fix that - or does it have to be replaced?

SWG (salt water chlorine generator) - no - not sure what that is? I got all the stuff from here for the bleach, borax and baking soda......and so far that has worked well. It is normal water in our pool, not salt water - does that make a difference or should we think of getting that?
I think what Jason (and others) are looking for are your actual numbers....telling us "good - in proper ranges" is ok but sometimes its a combination of factors that gives the clues, like if your calcium is high that could be calcium scaling....

The more info you give us the better.... :-D