Stenner pump stopped working.....

gle123

Member
Oct 17, 2019
16
Houston Texas
Any one have a stenner pumping chlorine that has stopped working? I was over at mine just now when it started up and the motor is running but the gears are not turning the rollers., so its not pumping. have had it running about 4 months, has worked perfectly until now. anyone had this happen? does the pump need to be replaced? thoughts? its a
3gpd 100psi fixed flow model.

Thanks for any help anyone can provide....

Garrett
 

gle123

Member
Oct 17, 2019
16
Houston Texas
oh nice, so we can ping Stenner right here on these threads...? see if they come back with anything before I jump to buy another one, i do see their warranty is 1 year so i am inside that. I looked at the pump a little and did not see anything out of place/loose, its like the gears are broken or something similar. hoping to get something figured out before next weekend, going out of town for three days, and really dont want to put pucks in.
 
  • Like
Reactions: GDN

GDN

Bronze Supporter
Oct 17, 2016
483
Dallas, TX
oh nice, so we can ping Stenner right here on these threads...? see if they come back with anything before I jump to buy another one, i do see their warranty is 1 year so i am inside that. I looked at the pump a little and did not see anything out of place/loose, its like the gears are broken or something similar. hoping to get something figured out before next weekend, going out of town for three days, and really dont want to put pucks in.
They do have a representative that comes here to offer support. If they are only on during work hours, it maybe Monday before you hear from them.
 

gle123

Member
Oct 17, 2019
16
Houston Texas
So I pulled the pump off the tank to take a closer look. The motor/gears are turning and they turn the shaft, but when I put the load of the rollers on the motor it does not turn the rollers.,, I can turn the rollers by hand so nothing is binding it up., and sounds like the gears are making more noise when i put load on them, like maybe they are slipping/stripping with the load, although the gears look good to me. so, looks to me like i wont be able to fix this. I bought this from poolweb and they have a credit guarantee for the first year on these, so I think fastest route to fix is hopefully use some credit(50% of original price between 5-8 months from purchase) towards buying a new pump. only thing i am also realizing after using this one for short time is I want the 10gpd pump now instead of the 3gpd pump(basically same price), hopefully i can use some of that credit towards a 10gpd model. would really like to get chlorine in faster so my dosing window is much smaller than what the 3gpd is doing now...
 

Stenner Tech Support

In The Industry
Apr 14, 2020
66
Florida
actually looking at my older thread i have only had this running for about 3 months.... hope these pumps in general last much longer than this, likely just got unlucky with this one.?
Hi,

We are sorry you are having issues with the pump. It appears the roller assembly hub may be cracked which results in the rollers turning on the shaft. Please do not purchase another pump as this pump is easy to repair. You can also change the pump tube to #2 (UCCP2FD) and get the 10 GPD. If you are able to contact us, we can troubleshoot the issue. What is the serial number from the pump? We are attaching the Basic Service Manual which may help.
 

Attachments

  • Stenner Basic Service Manual.pdf
    2.8 MB · Views: 7
Last edited by a moderator:
  • Like
Reactions: GDN

gle123

Member
Oct 17, 2019
16
Houston Texas
ok i will contact tech support., would i need to replace the pump head assembly? as i said above pump motor and shaft turn, but when i load it with the rollers it wont turn. how quickly would that be able to get to shipped to me? really need to try to get it fixed before this Friday if possible. so if i just replace the current #1 tube with the #2 tube i am at 10gpd with this current pump motor/gearing etc?.
Thanks.
 

Enjoying this content?

Support TFP with a donation.

Give Support

Stenner Tech Support

In The Industry
Apr 14, 2020
66
Florida
ok i will contact tech support., would i need to replace the pump head assembly? as i said above pump motor and shaft turn, but when i load it with the rollers it wont turn. how quickly would that be able to get to shipped to me? really need to try to get it fixed before this Friday if possible. so if i just replace the current #1 tube with the #2 tube i am at 10gpd with this current pump motor/gearing etc?.
Thanks.
Hi,

If you could provide the serial number from the pump, that will be a great help. If it is the roller assembly hub that is cracked, the roller assembly would need to be replaced. The motor will turn the rollers with any size tube with no issues. We hope this helps.

Email us at [email protected]

Thank you for using Stenner Pumps.
 

Mike1162

Silver Supporter
Jun 13, 2015
1,104
N Tonawanda, NY
ok i will contact tech support., would i need to replace the pump head assembly? as i said above pump motor and shaft turn, but when i load it with the rollers it wont turn. how quickly would that be able to get to shipped to me? really need to try to get it fixed before this Friday if possible. so if i just replace the current #1 tube with the #2 tube i am at 10gpd with this current pump motor/gearing etc?.
Thanks.
With the rollers installed can you tell if just the rollers aren't turning or if the shaft also isn't turning?
 

gle123

Member
Oct 17, 2019
16
Houston Texas
serial number is 010720NY0000283 I did email support and received email back from Michael Kinney... sounds like i would need to send pump in for warranty/fix etc. which i can do, but i do not want to be without a pump for weeks etc. really want to get something working before this weekend., is there a way i can tell if the roller assembly hub is cracked and new assembly and #2 tube sent to me this week?
 

Stenner Tech Support

In The Industry
Apr 14, 2020
66
Florida
serial number is 010720NY0000283 I did email support and received email back from Michael Kinney... sounds like i would need to send pump in for warranty/fix etc. which i can do, but i do not want to be without a pump for weeks etc. really want to get something working before this weekend., is there a way i can tell if the roller assembly hub is cracked and new assembly and #2 tube sent to me this week?
Hi,

The best way to tell if the roller assembly hub is cracked, is to remove the tube housing cover (front cover), start the pump and see if the shaft that goes through the roller assembly is turning and the rollers are stationary. That is an indication for a cracked roller assembly hub.
 

gle123

Member
Oct 17, 2019
16
Houston Texas
ok so roller housing assembly is not cracked... it looks good, and when i turn pump on the shaft does NOT spin. but when i take the roller assembly off, the shaft does spin. so with load it will not spin, has to be a gearing issue, and when i manually turn the roller assembly with pump off the shaft will turn but i also hear what sounds like some slipping in the gears.
 

Stenner Tech Support

In The Industry
Apr 14, 2020
66
Florida
ok so roller housing assembly is not cracked... it looks good, and when i turn pump on the shaft does NOT spin. but when i take the roller assembly off, the shaft does spin. so with load it will not spin, has to be a gearing issue, and when i manually turn the roller assembly with pump off the shaft will turn but i also hear what sounds like some slipping in the gears.
HI,

It appears you will need to send the pump in as assigned. We are sorry for the issue.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread