Sta-Rite Max-e-therm 200 Natural Gas pool heater

DonConklin

Member
May 24, 2020
6
PA
Hello,
I've researched the forum and see many posts regarding this heater but I have been unable to track down the source of my particular issue. I have the Sta-Rite NG heater on my pool. It is old but its works (intermittently). My issue is that the heater will reach a certain temp and then cycle on and off. During the course of cycling on and off, the heater will not display any error codes and none of the LED indicators on the back of the board are illuminated. I have replaced all sensors to include stack sensor, the thermistor, both high limit switches, the thermal regulator, the water pressure switch, the air flow switch, the control board (twice), the membrane (since the new board has a different digital readout). I checked the burner to see if there is a leak in the chamber but it's dry.
The heater fires up and runs without fail up to about 80 degrees. From that point....the cycling starts. The burner cuts off and then re-fires about 20 seconds later. This will continue non stop, climbing in temp slowly but the cycling on and off isn't necessarily the most effective way of heating. I checked the control board programing, the high limit is set to 101 currently but I couldn't get close to that temp it if I wanted to. I checked my stack sensor and made sure it was set up correctly on the control board as well. I ran jumpers past the high limit sensors just to make sure I didn't have a faulty new sensor. There isn't much left to replace here but I am lost trying to figure out what I should try next. Any thoughts, guidance, suggestions would be appreciated.
Thank you in advance for any help!
Don
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
29,108
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
You replace part 7 - Manifold Bypass?


What pump do you have?

Short cycling is often caused by low water flow which can be due to a dirty filter.

You check the heat exchanger for scale?
 

DonConklin

Member
May 24, 2020
6
PA
I didn't replace the by-pass, I took the manifold off and inspected the bypass to insure it was working and not separated or broken. While the manifold was off, I looked at the heat exchanger tube ends.....while there was some buildup it was minimal, they appear to be in good shape. I also checked for any leaks in the exchanger but that seemed to be OK as well. The pump is a 1 horse pump that was replaced a couple of years ago. I always check my pressure and backwash as a routine. I often check and keep the chemicals balanced. I have salt pool and I am always checking the PH levels.
thanks
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread