Spa PSI higher than pool

RhoOmegaBeta

New member
Feb 8, 2020
4
Florida
Hi everyone,

When I set my valves to circulate the spa it's about 10 psi higher than if I run the pool plus spa (pool and spa returns on, main drain and skimmer on, spa drain off). Also the pump has a noticeable amount of air inside vs none when running the pool plus spa. Is this normal or do you think there's a suction side air leak in the spa?
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
29,038
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
What specific PSI's are you looking at?

What type of pump do you have?

Please create your signature with details of your pool, spa, and equipment.

You could have a suction side air leak by your pump. Post pics of your pump and valves.
 

Tres Gatos

Well-known member
Apr 13, 2019
87
Bullhead City, AZ
Does the pump increase RPMs when you set it in spa mode? That's normal for automation and would expect to see an increase of 10psi for the jets. At higher RPMs you might also expect some air bubbles due to pump cavitation.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,091
Bedford, TX
R,

Sounds normal to me.. The filter pressure is actually the amount of effort it takes to force water through the filter and all the plumbing and then back to the pool or spa.. When in the spa mode you have to force the water through the spa jets.. When you also turn on the pool, you now have more paths for the water to flow and the pressure drops.

Thanks,

Jim R.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread