SLConfig Sensor Calibration: Temperature Sensor Calibration Not Saving

utfanthomas1

New member
Jul 14, 2018
3
austin, texas
I have a Pentair Mastertemp gas heater and use the Screenlogic app to control just about everything for the pool/spa. No issues until recently when the heater would stop early according to app temp even though the heater icon was flashing indicating it was still on. I have since verified the temperature on the heater itself and a thermometer in the spa match and are about 10 degrees warmer than what the temp in the app is showing. This works ok as the spa will get to the setpoint, but once it reaches the discrepancy between the app and heater seems to not allow it to self regulate and it gets much too cold.

I have tried to go into SLConfig app to calibrate the sensor temperature sensor on the spa setting to what the thermometer/heater are reading. While in the app it seems to save, but once the window is closed it reverts back to the lower non-matching temperature.

Any suggestions on how to correct this?
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
33,378
Laughlin, NV
You may need a new temperature sensor for your system. The ET (since you have Screenlogic I assume you have an EasyTouch - please update your signature) uses the temperature sensor installed in your piping to control the heater. It does not use the temperature readout from the heater.
 
  • Like
Reactions: utfanthomas1

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
19,495
Bedford, TX
Thomas,

I too would replace the pool water temp probe..

I have also had some trouble getting the temp to cal... Seems to me I had to do it two or three times, before it would stick.. If I remember correctly, I set it, change to another set up page and then went back and set it again and then hit finished.. Not sure this will fix it, but something to try.

Once I get it to stick, it stayed there.. I was making air temp higher than actual, to prevent the freeze control from coming on too early.

Thanks,

Jim R.
 
  • Like
Reactions: utfanthomas1

panic_button

Bronze Supporter
Jun 23, 2019
163
Panhandle Florida
Can you swap out the air and water temp sensor to see if the issue follows? I had issues with the calibration not working via the app and now do it via the ET outside. It takes a few minutes for the new temp to show up for me.
 
  • Like
Reactions: utfanthomas1

utfanthomas1

New member
Jul 14, 2018
3
austin, texas
Thank you for the replies! I do have an ET. Based on these suggestions I may try to calibrate the water temp sensor from the ET and see if it will save. The main issue is it is not saving from the app. Or it’s faulty.

This is what I understood. Please correct me if wrong. The ET sends the set point to the heater which kicks it on initially. Then the heater display and thermometer in the spa match and rise together. The App temp lags (based on comments likely due to failing or out of cal water sensor sending feedback to ET and thus the app).

Does it make sense that the heater shuts off when it reaches set point (made on app) on its display? If the ET is controlling the heater and thinks it is 10 degrees cooler than it is, shouldn’t the heater stay on until the ET shuts it off? The app still appears the system is running with flashing ‘Heater’ button, but in fact the heater is off.

I’ll update after the calibration try from ET.

Thanks again and please let me know why the heater shuts off if being controlled by ET if you have thoughts.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
19,495
Bedford, TX
Thomas,

The heater should be set to full hot... Then the ET measures the pool/spa water temp.. If the temp is below the set point you have set up in ScreenLogic, a small relay will close and turn the heater on.. The heater will stay on until the ET measures that the water temp is at or above the set point. This will shut the heater off..

If you have the heater set to a max of 90 degrees and tell the ET to run the heater until the water is at 100 degrees the heater will stop heating at 90, but the ET does not know that and will keep thinking the heater is on..

Thanks,

Jim R.
 
  • Like
Reactions: utfanthomas1