Should algae pass right through my sand filter?

PieterS

Bronze Supporter
Jul 1, 2020
100
Minneapolis, MN
I have an Intex sand filter on my ~5000 gal above ground pool. Ever since my SWCG tripped during a power outage on a 10-day vacation, trying to get ahead of an algae problem. But when I vacuum the bottom of the pool to get the (presumably?) algae off the bottom - it shoots right back into the pool via the return.

Should I be expecting my sand filter to be filtering out algae?? I tried to attach a pic of the return plume, not sure how well it shows.IMG_6904.JPG
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
44,373
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Intex systems are not very robust and thus can make filtering out small particulates difficult. You can try a deep clean of the filter to make sure there is no channeling.
 

PieterS

Bronze Supporter
Jul 1, 2020
100
Minneapolis, MN
And maybe let me rephrase the question - forget I said the word 'Intex'...

SHOULD algae pass right through a properly functioning sand filter?
 

CSE1965

Silver Supporter
Sep 12, 2021
9
Northern Illinois
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Intex Krystal Clear
I vacuum my debris and dead algae to waste setting on the filter housing then add water back if need be. It even states this on some brochures when using products that kill algae.
😀
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread