Seen floating above my skimmer

brunoforestier

Bronze Supporter
Apr 19, 2020
46
Denver CO
Can anyone identify what this is?

In the past 11 days, I have twice done a partial (40%) drain and refill of my pool, so I'm wondering if this is some kind of algae (or something?) buildup. My pool water otherwise looks fine. I haven't added chemicals yet - I have a broken glass problem that I have also just posted about moments ago...
 

Attachments

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
That is an odd look. Can you give us a few more details such as:
- Why did you need to exchange water (high CYA, CH, etc)?
- Do you recall what chemicals or products were added last winter at closing?
- Can you post a full set of water test results?

It would also help to know more about yoru pool and equipment in your signature. With all of that info, it should help.
 

brunoforestier

Bronze Supporter
Apr 19, 2020
46
Denver CO
I'm doing another drain (high CYA, last measured at 95 after last refill), so I'm not bothering with water testing for a while (doing a slow drain that takes days due to draining issues on my property).

Upon more inspection, my theory is these are spider webs floating around and collecting near the skimmer. I get a lot of spiders in the pool room and many drown in the pool water.

I'll report back after I'm done with my draining escapades!
 

brunoforestier

Bronze Supporter
Apr 19, 2020
46
Denver CO
I'm still not sure what to make of this, and after doing some partial drains and refills, I still see the same look as the original photo from May 4.

I've got pretty decent water quality at the moment:

4.2 FC
7.8 pH (aiming to lower that with MA)
110 TA
180 CH
10 CYA (estimated, not sure how to measure under 30)
 

Berger82

Well-known member
Feb 24, 2018
81
Richmond, TX
Can anyone identify what this is?

In the past 11 days, I have twice done a partial (40%) drain and refill of my pool, so I'm wondering if this is some kind of algae (or something?) buildup. My pool water otherwise looks fine. I haven't added chemicals yet - I have a broken glass problem that I have also just posted about moments ago...
I've had that in my skimmer before as well. No idea what it is but goes away after a day or so.