Search Issues

kafox001

Well-known member
Jun 10, 2019
49
New England
When trying to search for a keyword in a specific forum, I will type in the keyword and then choose the option for "This Forum" then click the GSearch button, but I am getting results from the entire forum group instead of the specific forum I am in.

For example, I am searching for "rebuild" in the "Under Construction" forum, but I am getting results from the entire "Equipment - Build, Use, and Repair" forum group.

This makes most of the results I get not relevant to what I am actually trying to find.

Is this a bug? Intended behavior? Is there a way to actually search in one specific forum?

EDIT: I can get the results I am looking for if I use the advanced forum search, but that functionality was broken for a while.

Thanks,
Kyle
 

JohnT

Admin
Mod Squad
TFP Expert
Apr 4, 2007
9,851
SW Indiana
Kyle, there have been some recent changes to the search function so this may be part of it. Tagging @Leebo so he can check on the issue. Thanks for letting us know. We can’t fix things unless people report problems
 

Leebo

Admin
TFP Expert
LifeTime Supporter
Jul 21, 2011
9,944
Eastern Ohio
The behavior you're seeing is actually working correctly, but not as expected. I'll pass it onto the developer to see if there's an easy fix.

As John mentioned we've altered the search as of late to utilize Google by default. As you've noticed if you use the "Advanced Search" it does use the older search and it would work. It was broken during a server swap a few weeks ago but should now be back up and running as normal.
 

kafox001

Well-known member
Jun 10, 2019
49
New England
Thanks for the quick responses!

Yea, advanced search does work now, but if Google search is going to be the default going forward, I would like to see it be able to search in one specific forum and not just a group of forums.
 

RMcGirr83

Gold Supporter
Nov 19, 2018
900
Tuscola, TX
The google search is an add-on and the issue you're having is due to this line in the add-on

It doesn't take specific forums into account but rather the term being searched on. It would be the same if you googled it using normal methods (eg, rebuild site:troublefreepool.com).
 

kafox001

Well-known member
Jun 10, 2019
49
New England
The google search is an add-on and the issue you're having is due to this line in the add-on

It doesn't take specific forums into account but rather the term being searched on. It would be the same if you googled it using normal methods (eg, rebuild site:troublefreepool.com).
But - it gives an option to search "this forum" so what does that option do if it doesn't take into account a specific forum?