ScreenLogic2 with Gigabit Internet Issues...

oakley6575

Member
Mar 17, 2021
13
Las Vegas, NV
I'm having a lot of trouble installing a ScreenLogic protocol adaptor to my system. I have Gigabit internet and Linksys MX4200 routers. I've spent countless hours on the phone with Pentair and they can't seem to resolve the issue.

It seems that the screenlogic is not communicating with the router due to it being a gigabit router. That is the only thing Pentair can come up with. I know the MX4200 dumbs the speed down to 10/100mbps for items that can not handle gigabit speed. Pentair says this protocol adaptor does not work at gigabit speeds but it should run fine on anything lower. I have proof through the routers reporting that it is in fact dumbing the speed down on the ethernet port it's connected to, but the adaptor will not connect or obtain an IP.

I can't get it to show up in the config or control app and Pentair shows that my model number has never been connected to their servers meaning its never seen an IP address. I really feel that the adaptor itself is bad but they won't say that. I've installed a slower router to my MX4200 and then plugged the screenlogic into that and it still won't connect... That should be proof the adaptor is bad but no one seems to think that.

Does anyone here have Gigabit speed internet with a screenlogic? Or have any of you professionals run into this issue? I really appreciate the help!
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
37,098
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Welcome to the forum!
From Pentair Automation Systems - Further Reading

ScreenLogic Remote Connection Error​

If you get " ERROR Cannot connect” after replacing the router, then you will have to reset the Protocol Adapter because you changed the router.

Push the reset button 3 times. It is inside the little hole in one end of the adapter.
I suggest you read ABC's of Pool Water Chemistry.
 

oakley6575

Member
Mar 17, 2021
13
Las Vegas, NV
Welcome to the forum!
From Pentair Automation Systems - Further Reading

ScreenLogic Remote Connection Error​

If you get " ERROR Cannot connect” after replacing the router, then you will have to reset the Protocol Adapter because you changed the router.

Push the reset button 3 times. It is inside the little hole in one end of the adapter.
I suggest you read ABC's of Pool Water Chemistry.
Thank you! We did this, maybe 25 times, while on the phone with multiple Pentair tech guys. It never established communication with their servers.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
37,098
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Be sure that your protocol adapter and the router are separated by some distance (not right next to each other). That has found to be an issue too.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
37,098
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Right now I have 5ft between them. Is that enough?
Should be.
I did a Search using Pentair Screenlogic Router in the search line. Try it and see if any of those threads help.
 

oakley6575

Member
Mar 17, 2021
13
Las Vegas, NV
None of the threads on this site or any on google apply to my issue. I've searched for three days before starting this thread. This thread is my last resort.

Does anyone have any real experience with ScreenLogic on a Gigabit network?
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
24,877
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Confirm we are discussing you having the PA connected to your MX4200 with a Cat5 cable and not WiFi?

You say you installed a slower router to your MX4200? What model slower router did you connect to?

Have you tried to connect by WiFi to a 2.4Ghz guest network?
 

oakley6575

Member
Mar 17, 2021
13
Las Vegas, NV
Confirm we are discussing you having the PA connected to your MX4200 with a Cat5 cable and not WiFi? - Yes, correct.

You say you installed a slower router to your MX4200? What model slower router did you connect to? - I've installed a google mesh router, and an apple airport express. Both routers had internet. I confirmed by connecting to their individual networks on my laptop and phone. The PA did not obtain an IP through either of those routers...

Have you tried to connect by WiFi to a 2.4Ghz guest network? - I have not.. How do I connect the PA via wifi?
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
24,877
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Google Mesh has problems connecting with Screenlogic. And I would not be confident about the Apple Express either. You need to try an old dumb Linksys WRT router. Basic 2.4 Ghz 80211 b/g. Not mesh.

Screenlogic has a real old chipset that has problems with mesh routers. It gets confused with multiple SSID networks. And WiFi passwords cannot have any special characters in it - only letters and numbers. And probably other quirks.

Forget the WiFi comment. The PA needs to be hard wired to the router. But folks with the fancy mesh routers like you have then have problems getting the WiFi app to connect to the PA.

What is your DHCP address pool range? When you try the old router have it do its own DHCP with the 192.168.0.XXX address range for the PA.
 
  • Like
Reactions: iain42

Enjoying this content?

Support TFP with a donation.

Give Support

oakley6575

Member
Mar 17, 2021
13
Las Vegas, NV
Range is 245 users. There are only 13 devices connected. When the old routers are plugged in, the PA is the only thing connected to them. Hardwired and wirelessly. I'm not sure I can narrow the issue down any more.. It's pretty clear to me the PA will not communicate through a Gigabit network. And then this particular PA I have, won't connect to any router... Am I missing anything to determine the PA is faulty?
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
24,877
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
I am not asking about the IP address range. I am asking if your IP address pool is using an IP adddress range different then 192.168.X.XXX?

All of Screenlogic is faulty when used with the modern mesh routers due to their antiquated chipset but Pentair will not admit to comparability issues. Most folks work around it by connecting it through an old router that works.

If your PA does not connect through one of the old routers that other folks PAs work through then it confirms a bad PA box.

@mknauss @Jimrahbe what manufacturer and model router does your PA connect through?
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
37,098
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
I do not have Screenlogic!! Jim will have fun with that --------
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
21,214
Bedford, TX
Oak,

I have an AT&T U-verse Modem.. The Ethernet output is connected to a NetGear ProSafe 8 port Gigabit GS108 Switch and the ScreenLogic Protocol Adapter is connected to it.

I have never had a connection issue.. We did get hit by lightning about 4 years ago and it took out a bunch of stuff including the modem, some Ethernet stuff and the Protocol adapter. Everything was replaced and it just fired right back up.

The only "mesh" I have is the kind to patch drywall with... :mrgreen:

Thanks,

Jim R.
 

NCMike

Gold Supporter
Jan 31, 2020
139
Raleigh, NC
You said you confirmed that your router’s port switched to 10/100 when the PA connected, is that correct? I assume you saw this in the routers app? Did you also check in the app under the devices section and make sure it did not get an IP address? Don’t assume it’s not getting an IP just because it’s not connecting to pentair’s servers. You can also use an app like Fing to check for IP addresses and devices connected to your network.
The MX4200 is a mesh system. How many of them do you have? Did you trying plugging the PA into the main router connected to your modem?

Confirm if it’s getting an IP address or not in the routers app first. If it’s getting an IP and not connecting to the internet we can figure that out later. My assumption is that it is getting an IP address since you stated
I have proof through the routers reporting that it is in fact dumbing the speed down on the ethernet port it's connected to

Also, do you have an ISP supplied modem? Would it happen to be a modem/router combo?
 

oakley6575

Member
Mar 17, 2021
13
Las Vegas, NV
You said you confirmed that your router’s port switched to 10/100 when the PA connected, is that correct? I assume you saw this in the routers app? Did you also check in the app under the devices section and make sure it did not get an IP address? Don’t assume it’s not getting an IP just because it’s not connecting to pentair’s servers. You can also use an app like Fing to check for IP addresses and devices connected to your network.
The MX4200 is a mesh system. How many of them do you have? Did you trying plugging the PA into the main router connected to your modem?

Confirm if it’s getting an IP address or not in the routers app first. If it’s getting an IP and not connecting to the internet we can figure that out later. My assumption is that it is getting an IP address since you stated

Also, do you have an ISP supplied modem? Would it happen to be a modem/router combo?

Yes, I’ve verified through the app and by logging into the router that the PA is not obtaining an IP. It never shows up in the device list. If I unplug the PA, and plug my computer into the same port, using the same Ethernet cable, my computer shows up in the device list, it has internet, and an IP address. That tells me the cable and port in the router function properly. That same port shows to be running at gigabit speed in the routers report as well. If I plug the PA back in, the router switches to 10/100mbps, but the PA does not show up in the device list. Zero communication from the PA.

I have the PA connected to the main router that is connected to the modem. It’s not connected to any of the child nodes. The modem is a netgear CM1000. I’m assuming you guys will tell me I have to run equipment from 2005 for this PA to work? :ROFLMAO:
I still believe the PA is bad. Why am I wrong?
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
24,877
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
How old is the PA?

This a new ScreenLogic box? Return it as defective to where you bought it.
 

NCMike

Gold Supporter
Jan 31, 2020
139
Raleigh, NC
It’s definitely defective. You’ve done all you can do. They can’t expect you to have a 20 year old 10/100 router/switch laying around in the year 2021. Your router is working properly by switching to the slower 10/100 port speed so it’s communicating with the PA. The PA is just refusing to take the IP address.

The only other idea I would have is if you know the MAC address of the PA, maybe it’s listed on it somewhere or the box that it came in, you can do a reservation in the router for that MAC address and assign it a static IP. I don’t know, that’s a long shot but who knows.
 
  • Like
Reactions: MyAZPool

oakley6575

Member
Mar 17, 2021
13
Las Vegas, NV
It’s definitely defective. You’ve done all you can do. They can’t expect you to have a 20 year old 10/100 router/switch laying around in the year 2021. Your router is working properly by switching to the slower 10/100 port speed so it’s communicating with the PA. The PA is just refusing to take the IP address.

The only other idea I would have is if you know the MAC address of the PA, maybe it’s listed on it somewhere or the box that it came in, you can do a reservation in the router for that MAC address and assign it a static IP. I don’t know, that’s a long shot but who knows.
Worth a shot. I just don't know where to find the MAC address. I'll go through the box right now.
 

Enjoying this content?

Support TFP with a donation.

Give Support