Sand filter pressure consistently a bit higher than usual

Triplejnj

Well-known member
May 16, 2015
64
Jackson, NJ
Pool Size
16000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
Wondering if anyone has any thoughts. My pool is about 7 years old and since the beginning the filter pressure has almost always run at about 15psi. For some reason, a few weeks after opening the pool this season it started running consistently at about 17-18psi.
The filter is clear - I have backwashed several times since then and the pressure remains the same.
All water numbers are in check.
The sand in the filter was replaced at the beginning of last season.
Pressure gauge was replaced and measures same as previous so don't see any issue with it.

I know the jump in pressure is not severe, but it is still bothering me because it's always been at 15. :confused:
 

mas985

TFP Expert
LifeTime Supporter
May 3, 2007
14,686
Pleasanton, CA
Pool Size
20000
Surface
Plaster
Chlorine
Salt Water Generator
Any changes in the valve settings downstream of the filter will change filter pressure. In fact, any changes in the plumbing at all will change the filter pressure.
 

Triplejnj

Well-known member
May 16, 2015
64
Jackson, NJ
Pool Size
16000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
Thanks for the response. Valves are all open fully. It seems that there is also weakened suction in the skimmers. Pressure from the return jets seems fine, but water is not moving around as much and leaves and such not getting pulled into the skimmers (2). I dont think theres an obstruction in the plumbing because it's both skimmers and if i close the valve on one I do get slightly stronger suction in the other.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.