Sand Filter Issues - Debris re-entering through returns

batesjer

Silver Supporter
Jun 26, 2019
15
East Lansing michigan
I've been trying to troubleshoot my sand filter today, at least I'm learning a little bit about how it works. It has a side installed MP valve. I know large particles are bypassing the sand and re-entering the pool. Before I found this site I added CYA directly to skimmer and noticed it on my swim up ledges under the returns. Today I took apart the filter and used a wooden broom handle to break apart the sand in case there was channeling. I added a small amount of CYA directly to skimmer and it is still coming out of the returns. What are my potential issues? Should I take apart the multiport valve and inspect the spider gasket? I'm not sure of any other way debris that large could bypass my filter. Thanks in advance for any guidance here.
 

Flying Tivo

Well-known member
Jan 24, 2017
1,062
Monterrey, NL, Mexico
Can you gives a little more information? How old is the filter, when was the sand replaced? Have you used any Flocculants? You need to open up the sand filter, empty the sand to check for cracks in the stand pipe or laterals.
 

Flying Tivo

Well-known member
Jan 24, 2017
1,062
Monterrey, NL, Mexico
Yes I would highly recommend replacing the sand at this point as too many unknowns. Sand is rather inexpensive. Inspect both at the same time. Be prepared to buy a spider gasket, sold at most pool stores or online and some silicon lubricant as poolube.