Return jet pressure ok?

laweatherred

Well-known member
Jun 12, 2010
140
0
Levelland Texas
#1
This may not be the thread to ask this question, but...if I may....

I have the opposite problem with my jet flow/pressure.....it is super fast!!!

We did change our sand about three years ago....we have a 1hp pump....unfortunately I have no idea what size my filter is....(I can't find that paperwork)... :x

We installed a Intex SWG this year.....but just curious if too much jet flow is bad???

BTW....the pressure gage has maintained at about 15-16 since we turned it on this season.

Please, any feedback about this is greatly appreciated!!!!
 

laweatherred

Well-known member
Jun 12, 2010
140
0
Levelland Texas
#9
Ok....I see the "Img" tab here, but not too sure how to use it to insert my pics.....sorry, still learning how to use this site!!!

I have pics ready to insert if someone can explain to me how to get them listed. Thanks!!!
 

linen

LifeTime Supporter
TFP Expert
Jul 30, 2010
8,649
0
48
Twin Cities, MN
#14
laweatherred said:
Nope no label....the measurement, right along the blue band are 65 1/2 inches....what does that tell us??
It tells us it is a 20.8 inch diameter(to the outside of the shell), so we will assume it is a 20" filter or 2.2 sq. ft.

That pump is towards the high end for that filter size, but should work. In fact, I have the 1 hp 2-speed version of your pump on a 20 inch filter and it works fine without channeling, though my plumbing will be different, so my flow may be different from yours. The flow at my return (I have a 3/4" return eyeball) is fast enough to be uncomfortable on your back if you are close to it.
 

laweatherred

Well-known member
Jun 12, 2010
140
0
Levelland Texas
#15
Thank you so much linen......my return flow would be about the same (against your back that is).....but I guess it works. I'm just proud to have my pool up and running this year...after two past summers of green water!!!! Thanks again!!