Reinstalling Sta-Rite S8D110 Clamps So They Don't Leak

Mark Shvitz

Member
Jun 20, 2018
19
Gainesville, FL
I am trying to get my filter to stop leaking. I try following the instructions (alternating sides as I tighten clamps), but the filter still leaks. Is there a trick to this?
 

Mark Shvitz

Member
Jun 20, 2018
19
Gainesville, FL
Thanks for the reply. I was talking about the entire filter, not something that would use an O-ring. I finally got it working. I had to make sure the clamps were aligned carefully before tightening them, because they do not align themselves.
 

Bama Rambler

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2009
23,062
SouthWest Alabama
I was talking the large housing o-ring that's between the vessel halves. If it's dry it can prevent the housing from going together correctly.
 

Noob

New member
Jan 11, 2019
2
Las Vegas, NV
Thanks for the reply. I was talking about the entire filter, not something that would use an O-ring. I finally got it working. I had to make sure the clamps were aligned carefully before tightening them, because they do not align themselves.
So glad I saw this. Took mine apart this past weekend to hose the cartridges down and now, after putting everything back together, there's a very slight water drip from under one section of the "lip?" Looks like I'll be redo-ing it this coming weekend. I noticed too that a couple of the spokey-wheel things that fit over the large screws (sorry, not familiar with terminology) broke in half so I just left them off. Do you think I should try to track down replacements?
 
Thread starter Other Threads of Interest Forum Replies Date
P Under Construction 1
W Above Ground Pools 1
J Pumps, Filters, and Plumbing 1

Other Threads of Interest