Pump started making loud noise lately

Eric2021

Member
Apr 11, 2021
14
California
My Pentair WhisperPro pump started making noticeably louder noise recently:
How can I tell if it’s an issue with impeller or motor? This was installed by the previous owner probably in 2007, is it about the time to replace rather than repair the pump?
 

Eric2021

Member
Apr 11, 2021
14
California
Do you mean feel the impeller after turning on the pump with the basket removed? The water is still flowing from the skimmer so I have assumed the impeller is still working?
If it's really the motor bearings are shot, is it worth fixing that (I may have to hire someone to do it) or should I just replace the whole pump given its age (13 years)?
 

wireform

Silver Supporter
In The Industry
Aug 15, 2017
3,115
Spring Valley, NY
Do you mean feel the impeller after turning on the pump with the basket removed? The water is still flowing from the skimmer so I have assumed the impeller is still working?
If it's really the motor bearings are shot, is it worth fixing that (I may have to hire someone to do it) or should I just replace the whole pump given its age (13 years)?
As I stated motor off , breaker off to feel if there debris at the impeller. Usually this noise is bearing related. You can change the motor end and reuse the wet end if that's in your comfort zone
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread