Pump pumping air on start-up

tnthudson

LifeTime Supporter
Mar 31, 2008
353
Central VA
I'm a member here, but my buddy isn't...he has an inground pool with a Hayward "Super-Pump"(?) and I know he has a sand filter...
anyway, he's just opening his pool this season and he says the pump is pumping air into the pool, so that it creates bubbles/foam. He's had it happen before, but took the top off the pump and made sure his gasket was okay, and the problem stopped on that occasion.
This time, however, he checked his gasket and even applied some Vaseline (I think?) to it to be sure it sealed, but the pump is still putting air into his pool. He can't tell where air could be getting into the system anywhere else. He's had the pool forever, so it shouldn't be a 'noobie' mistake.
Any ideas? thanks
 

JohnT

Admin
Mod Squad
TFP Expert
Apr 4, 2007
10,006
SW Indiana
Pool Size
21000
Surface
Vinyl
Chlorine
Liquid Chlorine
Pump drain plug O-rings? Water level in the skimmer or sticking skimmer weir? Clog in the skimmer piping? Anything new in the system?
 

spishex

TFP Expert
Oct 12, 2008
1,375
Hillsborough, NC
No vaseline on the gaskets, please.

You should also check the pump inlet (male adapter threads) and any fittings on the suction side plumbing, especially unions and valve stems.
 

tnthudson

LifeTime Supporter
Mar 31, 2008
353
Central VA
Thanks, that's exactly what he did...it's a bad valve on his skimmer line. He's handy enough to work with plumbing (unlike me), so he thinks he's got it licked. :)
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.