Pump pressure problem

Etek14

LifeTime Supporter
Aug 6, 2008
42
My pressure output from return is less than it used to be. It seems to be better after being off for a while. The pressure reading is at the start indicator and I have backwashed just to be sure. The basket in the pump is clear. WHat could cause this kind of behavior.

Thanks
 

Etek14

LifeTime Supporter
Aug 6, 2008
42
Filter pressure is at or below the start level, no where near clean filter level. It may be less than normal, Mainly the flow output at the return is less. Usually I have a good solid push of water out the return and the fountain is spraying at least a foot in the air. (I have the combo return and fountain attachment and its set where I usually have it). If I shut the pump off for awhile the pressure seems to return and gradually go down to a point. You think I may have a lower than normal filter pressure from what I had? I can check again when I get a chance.
 

mas985

TFP Expert
LifeTime Supporter
May 3, 2007
12,421
Pleasanton, CA
It would help to know the normal filter pressure and the current pressure. If the filter pressure has dropped from normal combined with low flow rate, it is likely caused by a suction side problem. That can either be a pipe blockage or an impeller clog. If you have air in the pump basket it is probably a pipe blockage. Did you recently clean up the pool with lots of vacuuming?
 

Etek14

LifeTime Supporter
Aug 6, 2008
42
I have done some vacuuming but nothing major, I will check the pipes. I had a small bubble in pump basket.

I'll try to come up with the presssure readings I had. Thanks for the help. I will post back on what I find.
 

Other Threads of Interest