Pump motor overheating, unit likely shot. Replacing opinions wanted

Ezz

Member
Mar 4, 2019
19
AZ
Hi All,

I bought my house 2 years ago from a guy who had rented it out for years and from the looks of it I would say the pool equipment (pump and motor) looks to be a good 8-10 years old. Equipment was running fine since purchase, but about a month ago the pool pump would suddenly stop mid cycle. I replaced the run capacitor and it went back to working fine. Then today I noticed it had again shut-off at some point mid cycle. I attempted to restart and it just hummed for a minute and shutoff again. So I replaced the start capacitor. Attempted to start and the motor started spinning and after about a minute it shutoff again and I noticed a burning smell, the unit was also blazing hot.

I let it cool down for a few hours and took the unit apart. No impeller blockage, and the motor shaft spins freely in both directions. I did however discover a decent amount of corrosion and rust on the motor itself and the internals are pretty ugly. The internals of the pump are not great either - some cracks and discoloration.

I had hoped to just order a new motor and seals and replace them - easy enough. But seeing as this equipment is just old and shot, maybe its time to replace the entire unit? I have plenty of experience as a DIY guy with regards to mechanical and electrical applications - but 0 plumbing. Based on the picture provided will I be able to effectively cut the old piping, and install a new pump directly? (It looks pretty tight to me). I have some worries this might require some extensive pipe replacing that might be tough for a noob like me.

Appreciate any advice you can offer.

Thanks,
Joe
 

Attachments

guinness

Well-known member
May 3, 2019
553
California

Ezz

Member
Mar 4, 2019
19
AZ
Yeah definietly going to use those. Just hoping I can fit the new piping in without having to rip out and replace the valve housings, etc.

Also - my pump has been down 2 days already - looks like to ship in a new unit is 5-7 days, how the heck am I supposed to keep my pool from turning into a green swamp for that long without a pump? I am in Arizona so its this is great timing at 110 everyday.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
33,955
Laughlin, NV
how the heck am I supposed to keep my pool from turning into a green swamp for that long without a pump?
Add liquid chlorine and raise your FC level to near SLAM level. Maintain that each day, using a brush or by swimming to mix it in. If you have a sump pump, you can use it to move the water around. Chlorine is paramount.
 
  • Like
Reactions: guinness

Ezz

Member
Mar 4, 2019
19
AZ
Add liquid chlorine and raise your FC level to near SLAM level. Maintain that each day, using a brush or by swimming to mix it in. If you have a sump pump, you can use it to move the water around. Chlorine is paramount.
Ok - thats the plan - been keeping adding chlorine like mad since this morning. thanks

Are you near Mesa? You could call Wholesale Pool Equipment and pick up a replacement pump.
Not too far - I will check them out thanks
 
Last edited:

FS2019

Member
Jul 21, 2020
16
Tucson, AZ
My pump was off for 10 days this July under brutal AZ sun, and I got by by adding LC every night and using a 1/3 HP submersible pump to move water from one end to the other end of the pool like Martin suggested. Except dirt settled on the floor, the water has been clear.
 

Ezz

Member
Mar 4, 2019
19
AZ
I have been brushing every 6-8 hours for the last 2 days and keeping chlorine high. My kids swam quite a bit during the first few days which helped keep things flowing. As of now I am not seeing any visible signs of algae and I am replacing the unit tomorrow morning so hopefully I am back up and running tomorrow afternoon and can avoid a mess. Thanks all