Pump did not prime on skimmer side

mumgoa

Well-known member
Jul 13, 2015
68
Novi/MI
Surface
Plaster
Chlorine
Liquid Chlorine
Hello,

It's time to open the pool on 5/25

When we closed the pool on 9/8, we discovered a priming problem

All through last season, my filter gauge was at around 23 psi when the valve was set to draw from main and skimmer

Towards the end of summer, the psi dropped to 20. The return jet power seemed adequate

When I checked the gauge one day prior to close, the psi was 15 on main only and 15 on skimmer only and 20 with both

However, on 9/8, the pump just would not prime on skimmer side and psi on main was at 15

SO, I guess, does it look like a skimmer side leak? The Oring on pump looks good and well lubricated

The opening guys said they will open and I am hoping the main works so I can use the pump for 2-3 weeks on main only. The guys said they can look at the a leak by pressure testing around 6/10 due to busy open demand

It's a 20 x 32 gunite pool wth a Pentair pump

Any other suggestions?

Thanks
 

reggiehammond

Gold Supporter
Oct 4, 2020
373
Fort Worth, Texas
Pool Size
30000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
Hello,

It's time to open the pool on 5/25

When we closed the pool on 9/8, we discovered a priming problem

All through last season, my filter gauge was at around 23 psi when the valve was set to draw from main and skimmer

Towards the end of summer, the psi dropped to 20. The return jet power seemed adequate

When I checked the gauge one day prior to close, the psi was 15 on main only and 15 on skimmer only and 20 with both

However, on 9/8, the pump just would not prime on skimmer side and psi on main was at 15

SO, I guess, does it look like a skimmer side leak? The Oring on pump looks good and well lubricated

The opening guys said they will open and I am hoping the main works so I can use the pump for 2-3 weeks on main only. The guys said they can look at the a leak by pressure testing around 6/10 due to busy open demand

It's a 20 x 32 gunite pool wth a Pentair pump

Any other suggestions?

Thanks
Do you have air in your pump pot? If no air, there’s likely no suction side leak and PSI is the wrong metric to follow. I am guessing you aren’t seeing major bubbles from the returns?

When was the last time you cleaned your filter? PSI and flow issues can be a plugged/dirty filter easier than many other things.
 

mumgoa

Well-known member
Jul 13, 2015
68
Novi/MI
Surface
Plaster
Chlorine
Liquid Chlorine
Can you post a pic or two of your equipment pad and pool itself? Might help give us some ideas.
Hi Texas splash,
The equipment and pool is covered but here are some older pics
Thanks
 

Attachments

  • IMG_0661.jpg
    IMG_0661.jpg
    74.9 KB · Views: 4
  • IMG_2729.jpg
    IMG_2729.jpg
    130.8 KB · Views: 4
  • IMG_1716.jpg
    IMG_1716.jpg
    112.1 KB · Views: 4

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2014
33,611
Texas, San Antonio/Marion, South-Central Area
Pool Size
17888
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
Appreciate the pics. Any chance you have some showing all the plumbing on the pad? That could be helpful if you have some in the archives somewhere. If not, we'll work around it.
 

mumgoa

Well-known member
Jul 13, 2015
68
Novi/MI
Surface
Plaster
Chlorine
Liquid Chlorine
Do you have air in your pump pot? If no air, there’s likely no suction side leak and PSI is the wrong metric to follow. I am guessing you aren’t seeing major bubbles from the returns?

When was the last time you cleaned your filter? PSI and flow issues can be a plugged/dirty filter easier than many other things.
Hey Reggie,

SO when the valve is set to main, the pump works super fine - no air at all and full on prime. There was 0 prime on skimmer side No bubbles from returns at all until 9/7. Since we discovered the issue during closing, I could not check for bubbles the day of closing when the prime issue on skimmer side was found out

Wouldn't the dirty/plugged filter cause an issue on the main side too?

What should be the checklist of items for diagnosis before we do the pressure test?

Thanks
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2014
33,611
Texas, San Antonio/Marion, South-Central Area
Pool Size
17888
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
There was 0 prime on skimmer side
Sounding a bit like a clog of some sort. Do you have Drain King or other pressure type bladder device you can use to push water forwards and backwards between pump and skimmer to see if something gets dislodged in that suction line?
 
  • Like
Reactions: mumgoa

mumgoa

Well-known member
Jul 13, 2015
68
Novi/MI
Surface
Plaster
Chlorine
Liquid Chlorine
Appreciate the pics. Any chance you have some showing all the plumbing on the pad? That could be helpful if you have some in the archives somewhere. If not, we'll work around it.
The blue tarp is on the filter. The heater has the seran wrap. The valve is in the first pic in front of the Tagelus sand filter
 

Attachments

  • IMG_1007.JPG
    IMG_1007.JPG
    112.6 KB · Views: 4
  • IMG_2730.jpg
    IMG_2730.jpg
    110.9 KB · Views: 4

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2014
33,611
Texas, San Antonio/Marion, South-Central Area
Pool Size
17888
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
Okay, so a very simple suction side. I would pursue the pressure bladder test. I doubt there's an air leak at the 3-way, otherwise you would have problems when on drain as well. But you're always welcome to check to be sure.
 

mumgoa

Well-known member
Jul 13, 2015
68
Novi/MI
Surface
Plaster
Chlorine
Liquid Chlorine
Sounding a bit like a clog of some sort. Do you have Drain King or other pressure type bladder device you can use to push water forwards and backwards between pump and skimmer to see if something gets dislodged in that suction line?
Thanks TS. I don't, I guess the pressure test would resolve that

Any checklist of items to perform in an order at the open?

i was suspecting a skimmer side leak but it looks like there could be hopefully a smaller issue? Fingers crossed
 

Enjoying this content?

Support TFP with a donation.

Give Support

mumgoa

Well-known member
Jul 13, 2015
68
Novi/MI
Surface
Plaster
Chlorine
Liquid Chlorine
I want to count my blessings. Pool is open. Ran pump on main at 20 psi. Just swtched to skimmer only with fingers crossed. It struggled for about 30 seconds but primed great after that to 20 psi. Restarted and primed right away again. I have now set the valve to skimmer/main at 23 psi

As stated in initial post, at closing last year, the pump would not prime on a few attempts on skimmer only but primed just fineon main (9/8/2020)

Also, the day before closing, skimmer only and main only primed fine at 20 psi last year. There was no issue all of last year

While I am relieved, I am also curious as to what might have happened?
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2014
33,611
Texas, San Antonio/Marion, South-Central Area
Pool Size
17888
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
With no evidence of a blockage, I can only assume it has something to do with the way your suction lines are plumbed. Something effecting the way your skimmer pulls water. If it happens again or gets worse, let us know. We'll put our heads together and see if there's anything else you can do.
 
  • Like
Reactions: mumgoa
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread