pump cavitation sand filter noise please help

Amorphous

Member
Nov 25, 2018
6
White Plains, NY
Hello, looking for advice.

27ft round above ground pool.

I have had the same pump/filter for two years with no issues. This year I'm having and issue keeping the pump primed. The pump primes and works fine overnight. No air bubbles coming out of the return, no air bubbles in the pump basket. When I try turning the pump on the next day, it loses prime (all the water gets sucked out of the pump basket and Skimmer basket.). I've observed three issues that through searching leads me to believe pump cavitation is happening but I don't know how to fix. 1 when I open the pump basket I notice water vapor, 2 the pump is making a loud noise. If I apply slightly pressure to the pump with my hand it quiets down, 3 the sand filter is making a whoosing bubbly noise coming from the multiport valve. Can someone please advise how to continue to troubleshoot to resolve the issue of the pump losing prime when trying to turn it back on after being Darn off?
 
Last edited:

cowboycasey

Gold Supporter
LifeTime Supporter
TFP Guide
Jul 3, 2013
8,648
Southern OK
Pool Size
15000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
CircuPool SJ-40
raise the water in the pool.. If it is sucking air into the skimmer the pump will pull the air into the pump.. How high is the water level on the skimmer?
 

sktn77a

Gold Supporter
May 16, 2010
2,199
Chapel Hill, NC
I had a similar issue a couple of years ago (pump losing prime while off and that noise from the filter). It was an air leak. When I replaced the MPV all the problems went away.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.